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Symbols Used in the Manual 

 

 ……... Tips and Shortcuts 

…... Instructions for Advanced Users 

 

 



1 ABOUT THE MANUAL 

This user manual describes the functionalities of the IMiS®/View and IMiS®/Scan software 

products. Most of the functionalities are the same for both products, which is why the 

descriptions have been combined into a single user manual. 

 

1.1 About IMiS®/Scan and IMiS®/View products 

IMiS®/View is a software product for viewing and digitally signing all of the important graphics 

file formats (TIFF, PDF, JPG, GIF, BMP etc.). 

It enables the viewing of all image files which have been compressed using the standard CCITT 

G3/G4, LZW, JPEG, JPEG2000, JBIG and ZIP algorithms, and has been adapted for viewing  

multi-page documents. 

 

IMiS®/Scan is a software product for scanning black-and-white, gray and color documents, and 

for viewing and digitally signing documents. It supports the standard scanning formats  

(multi-page TIFF and PDF) and the viewing of all the important graphics file formats (TIFF, PDF, 

JPG, GIF, BMP etc.). The online settings of the scanning profile (resolution, color depth, 

brightness, sharpness, patterning, two-page scanning) facilitate the efficient scanning of paper 

documents of various readabilities and quality levels. 

 

IMiS®/Scan+ is a software product that, in addition to all the functionalities of IMiS®/Scan, 

also enables IP (image processing) filters to improve the processing of images (automatic 

alignment, rotation, noise reduction, automatic brightness adjustment, erasing empty pages, 

etc.) and the detection of documents in the process of scanning. 

 

IMiS®/Scan++ is a software product that, in addition to all the functionalities of IMiS®/Scan+, 

also enables optical character recognition (OCR) and immediate conversion of scanned 

documents into a textual form. 
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1.2 Chapters solely for IMiS®/Scan users 

In order for the user manual to be clearer, chapters are listed which contain merely the 

functionalities of IMiS®/Scan and are therefore not intended for IMiS®/View users. 

The IMiS®/View application is the same as the IMiS®/Scan application but without scanner 

settings and the scanning option. 

Chapters which are intended solely for IMiS®/Scan users are Product setup and Scanning and 

Setting options – Scan. 

 

1.3 New functionalities in this version 

We have implemented the following new functionalities and improvements to the previous 

certified version 10.3.2210 of the IMiS®/Scan and IMiS®/View module: 

 

Improvements: 

• Improved display of scaled Pallete color images.  

• The “Crop” operation works on rotated and mirrored pages. 
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2 GENERAL ON SCANNING DOCUMENTS 

2.1 Methods of scanning documents 

Scanning is the converting of documents in paper form into a digital data file for the purpose of 

viewing and saving to storage media. Paper documents can be captured using specialized 

scanners, multifunction devices or digital cameras. 

A scanner is still the most suitable for capturing larger quantities of paper documents.  

A scanner can be connected locally or via a computer network.  

Based on our experience in scanning, it is recommended that you connect the scanner locally. 

 

2.2 Connecting a scanner 

In order to successfully convert paper documents into digital form, you need software in 

addition to hardware (scanner and computer). 

In order for various scanners and the IMiS®/Scan software product to successfully scan paper 

documents, you must take into account the preset protocols or standards for connecting and 

transferring digital contents. The best-known standards are ISIS, TWAIN and WIA. 

 

ISIS 

ISIS (Image and Scanner Interface Specification) is an industrial scanner interface. 

It was developed by Pixel Translations in 1990. Today this standard is owned by the OpenText 

Corporation, which sees to its development and use. Any scanner manufacturer may develop 

its own ISIS drivers, but must obtain a certificate of compatibility with the ISIS standard from 

OpenText. In doing so, it must pay a license fee to OpenText. In general, all production scanners 

use ISIS drivers. 
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TWAIN 

TWAIN (Tool Without An Important Name) is a free scanning application programming 

interface. It was the first standard to enable the connecting of software to various scanners.  

The development of this standard is overseen by a consortium of large scanner manufacturers 

called TWAIN Working Group. 

 

A downside to this standard is that the user interface is integrated into the TWAIN driver,  

which makes it harder to implement the driver. Another problem is the long waiting periods for 

innovations. Generally speaking, low-cost scanners use only the TWAIN driver. 

 

WIA 

WIA (Windows Imaging Architecture) is a driver and API, developed by Microsoft. It only works 

on the Windows operating system. The entire development of the driver is tied to Microsoft's 

objectives and does not really take into account the demands of scanner developers. 

 

2.3 Scanning resolution and quality 

Scanning works on the principle of detecting light reflected off paper or picture.  

The entire surface of the sheet is divided into small pixels. Each pixel is determined by its 

position, brightness level and color (color scanning). Resolution is the number of pixels per unit 

of length.  

It is usually written down as number of dots per inch (dpi).  

A document which is divided into more pixels has better resolution and consequently its 

conversion into digital form is of higher quality. The scanning resolution is conditioned by the 

scanner technology. Scanners support a resolution from 100 to 1600 dpi. For the needs of 

archiving a non-image document, a resolution of 300 dpi is sufficient.  

Scanning with a resolution of under 200 dpi may result in unreadable conversion of archived 

documents. Scanning with more than 300 dpi is sensible if the original text on paper is of 

poorer quality or when you wish to convert an image of a document into digital form with very 

high resolution. 
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2.4 File compression and size 

When scanning, a dot on paper is being copied to a digital memory unit.  

In the case of black-and-white copying this unit is 1 bit, while in the case of gray or color 

copying it can be a byte or bytes. The quantity of color or level of brightness which is captured 

with a scanner is called color depth. Greater color depth gives a broader range of various 

colors and consequently means greater memory usage. The first row in the table below gives 

an example of how color scanning can use up to 15 MB of memory. 

 

Color depth  Black & white (1 bit) Gray (8 bit) Color (24 bit) 

none  475 KB  5 MB  15 MB  

CCITT G3  85 KB  x  x  

CCITT G4 T6  45 KB  x  x  

JBIG  36 KB  x  x  

JBIG 2bit  x  84 KB  x  

JBIG 3bit  x  165 KB  x  

JBIG 4bit  x  420 KB  x  

Packed bits  109 KB  5 MB  15 MB  

LZW  75 KB  3.2 MB  x  

ZIP  56 KB  3 MB  9 MB  

Wang JPEG  x  315 KB  363 KB  

Sequential JPEG  x  315 KB  360 KB  

Progressive JPEG  x  310 KB  334 KB  

 

Such quantities of obtained digital data may cause problems with the data transfer speed from 

the scanner to a computer or a lack of space on the storage medium.  

For this reason, digital data is compressed. The above table shows which compression 

methods are suitable for each color depth. Generally speaking, compression methods are 

divided into "lossless" and "lossy". 
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Lossless Data Compression 

The algorithms of methods in this group look for repeated strings in the digital document and 

shorten them without losing data. The quality of the scanned document prior to compression 

remains the same after the data is decompressed. The characteristic methods of this group 

are G4 T6, LZW and ZIP compressions. 

 

Lossy Data Compression 

A characteristic of the algorithm in this group is the removal of unimportant data from 

scanned documents and assigning similar pixels in the document to a common denominator 

(e.g.: it changes various shades of a blue sky into a single color for the entire range of blue 

shades). 

Thus, the original digital image is modified and the display quality is reduced.  

The decompressed image no longer matches the original. A representative of this group is 

JPEG compression. Repeated compressing and decompressing of an image may significantly 

affect the quality of a scanned document. 

Black-and-white scanning is sufficient for the majority of documents, which is why we do not 

recommend scanning in gray or color. The majority of scanners intended for document capture 

uses advanced methods and filters for graphic processing, which ensures the optimum quality 

of scanned documents. 

 

We recommend that you use lossless compressions for scanning text documents, and 

compressions from the JPEG family for image documents. For image documents which must 

preserve their source file you can likewise use the lossless compression method. 

 

2.5 Recording of scanned documents 

The recording of scanned documents to a storage medium is executed in preset file formats. 

There are different types of file formats; however, not all are suitable for a specific type of 

document. 

In general, file formats are divided into single-page and multi-page. In addition to a digital record 

of the document, all formats store additional information about the document in their 

structure. 
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Single-page formats 

Single-page formats are capable of recording only one page to a file. They are used for saving 

images and are suitable for the further processing of scanned images. The best-known formats 

in this group are BMP, PNG and JPEG. 

 

BMP 

BMP (Bitmap File Format) format enables the saving of digital images of random height and 

width in various resolutions and color depths. This format was developed by Microsoft to be 

used in its applications and the Windows operating system. The fact is that this format is well 

documented and patent-free, which is why it is present in all image processing programs. 

A flaw of this format is that it does not support data compression and therefore the files take 

up a lot of space on the storage medium. This format is not recommended for saving scanned 

documents. 

 

JPEG 

JPEG (Joint Photographic Expert Group) format was created in 1992 as an ISO standard for 

describing the procedure of compressing an image into a byte stream. A characteristic of this 

format is that the compression of the digital image affects the image display quality. 

The greater the compression level, the smaller the file and, consequently, poorer image quality 

when decompressed. The JPEG format gave rise to other versions of file formats for image 

recording: JBIG, JPEG 2000, sequential JPEG and progressive JPEG. 

 

This format is recommended for saving digitized photographs and images which contain many 

shades of color.  

Scanned text documents which contain sharp contrasts between adjacent pixels are not 

suitable for being saved in this format. 
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Multi-page formats 

Multi-page formats enable the recording of multiple pages into a single file. The best-known 

representatives are the TIFF and PDF formats. 

 

TIFF 

TIFF (Tagged Image File Format) format began to be developed in 1986 for the purpose of 

standardizing the saving of scanned documents from various scanners. It aimed to provide high 

functionality of various scanners and simplicity in exchanging scanned documents among 

various applications. It was designed for use in "desktop publishing". The format's structure 

enables the recording of various metadata about the document, in addition to the compressed 

digital document. The structure of metadata can be preset and known to many applications or 

merely to those which enable the displaying of said information. The entire file is dissected into 

identifiers, with each identifier being either a digitally converted document or information about 

the document (compression method, document size, resolution, color depth etc.). This format 

is present in all applications that are used for capture.  

Since 2009 the format has been owned by Adobe System, which sees to its upgrades and 

modifications. 

 

PDF 

PDF (Portable Document Format) format began to be developed in 1993 by Adobe System. 

Its purpose was to create a file format that would be portable between all file systems and 

applications. It was to represent a universal format for saving all kinds of computer-generated 

content. It was to be used for saving text products, images in vector or raster graphics and 

the other audio-video content. The PDF format enables the saving of a document in its entirety. 

Since its beginnings, the format has seen many upgrades and modifications. One version of the 

PDF format has become an ISO standard for the long-term archiving of computer-generated 

content (PDF/A). The PDF/A format guarantees the same content and appearance in various 

operating systems and applications. 
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3 TECHNICAL DOCUMENTATION 

3.1 Table of valid compressions for different types of files 

Not all file formats support all compression methods for all color depths. 

IMiS®/Scan supports all the known image file formats, of which the most commonly used are 

TIFF, PDF, JPEG, GIF, PNG and BMP. However, it saves only in a multi-page image format, i.e. 

TIFF or PDF/A.  

Table of valid compressions for saving files: 
 

Color depth Black & white (1 bit) Gray (8 bit) Color (24 bit) 

None TIFF TIFF TIFF 

CCITT G3 TIFF, PDF/A   

CCITT G4 T6 TIFF, PDF/A   

JBIG TIFF   

Packed bits TIFF   

LZW TIFF TIFF TIFF 

ZIP TIFF, PDF/A TIFF, PDF/A TIFF, PDF/A 

Wang JPEG  TIFF TIFF 

Sequential JPEG  TIFF TIFF 

Progressive JPEG   TIFF 

 

For rendering documents, we recommend black-and-white color depth using a CCITT Group 4 

compression method. The file format can be TIFF or PDF/A, which both ensure long-term 

archiving. If you wish to capture colors in a document without losing the quality of the scanned 

image, choose the ZIP compression method and the PDF/A file format. Some of the older 

viewers of TIFF files do not support ZIP, JBIG and LZW compression methods; hence 

documents which have been compressed using these methods cannot be displayed.  
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3.2 Location for saving documents 

A scanned document must be saved to a storage medium for later use and viewing. 

IMiS®/Scan uses a file system for saving scanned documents. 

The scanned document can be saved to a local disk, a network medium or external units  

(USB flash drive, external hard drive).  

 

Prior to saving them, all scanned documents must be named manually and the correct save 

location must be chosen. A document saved in this manner can be viewed subsequently in 

other programs that display files recorded in one of the IMiS®/Scan file formats. 

In this case the security level and access rights of individual users to these documents are set 

at the level of the Windows operating system rights. 

 

IMiS®/Scan which is activated within another application provides the option of saving directly 

to the IMiS®/ARChive Server. The entire saving procedure is automated. The user does not 

have to worry about naming the scanned document and the save location. A document saved in 

this manner is not visible in the file system and can be accessed only by another application.  

Moreover, the level of security and access rights to these documents can be set in another 

application, independently of the user rights of the Windows operating system.  

The rights to individual operations in IMiS®/Scan can also be set (e.g.: editing of already saved 

scanned documents is disabled in IMiS®/Scan). 

 

3.3 Annotations in a document 

Scanned documents in digital form can be subsequently added various visual notes or 

bookmarks. The most common are text and image stamps. 

 

Despite the fact that they are saved to the same file as the scanned document, subsequent 

annotations are not a part of the scanned document and can be removed.  

Should you wish for the annotations to be a part of the scanned document, you can merge 

them with the scanned document. Merging annotations with a document modifies the 

document, which is no longer the original scanned document, but a new version of the 

document. 
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3.4 Digital signing of a document 

In addition to viewing scanned documents, many applications also enable their modification.  

A slight change to the metadata of a scanned document gives us a new version of the 

document. Even if the change is not visible in the image of the scanned document, it can 

provide the user with different information about the very document (e.g. a change to the 

record of the author of the document may give wrong information about the original creator of 

the scanned document). 

 

In order to avoid all changes to the scanned document, it must be digitally signed prior to 

saving. Before using an digital signature, you must obtain a digital certificate, with which you 

identify yourself in the digital world. 

The digital certificate must be issued by a trusted public certification authority. 

A digital signature links the digital certificate data with the contents of the scanned document. 

This creates a uniform string of data, which is added to the scanned document file.  

The digital signature proves the authenticity and identity of the scanned document. 

 

IMiS®/Scan enables the saving of digitally signed documents only in the TIFF and PDF file 

formats; only the signature in the PDF format is standardly supported in other PDF viewers as 

well. The recording and verification of an digital signature in a TIFF file is a procedure which is 

integrated into the IMiS® software product family. 

 

When showing a signed document, the validity of the scanned document contents and digital 

certificate is verified. In the case of a digital certificate, the following is verified:  

• expiration date of the certificate; 

• whether the issuer has revoked the certificate; 

• whether the contents of the certificate have remained unchanged. 
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  Digital signing of documents is based on asymmetric cryptography.  

Each user signs a document with his or her private key. This private key is known only to the 

user and is saved in his or her digital certificate.  

The digital certificate is issued, together with the private key, by a trusted public certification 

authority. 

The certificate contains data which uniquely describes the person who owns the certificate. 

It also contains a public key which is used to verify the authenticity of the signed document. 

 

When a user signs a document, data about the digital certificate is also saved to the document, 

but without the private key. Only the public key is saved.  

The recipient of the signed document uses the signer's public key to verify the validity of the 

document. A valid signature proves that the signer is in fact the person who has signed the 

document. During the verification process the validity of the signer's digital certificate is also 

verified. 

 

The result of the verification of a digital signature is also displayed to the viewer of the signed 

scanned document visually. 
 

 
Image 1:  Displayed result of verifying the digital signature 
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4 SYSTEM REQUIREMENTS 

4.1 Hardware 

Most of the computers that can be bought on the market today meet the requirements of the 

IMiS®/Scan application. 

 

4.1.1 Minimum requirements 

• Intel Core i3 6 Gen processor; 

• 2GB RAM; 

• 200MB unused disk capacity; 

• network access using the TCP/IP protocol (IPv4 or IPv6); 

• USB connection to the scanner. All ISIS-compatible scanners are supported. 

 

4.1.2 Recommended requirements 

• Intel Core i5 6th Gen processor or more recent; 

• 4GB RAM or more; 

• 1GB unused disk capacity; 

• network access using the TCP/IP protocol (IPv4 or IPv6); 

• USB 3.0 connection to the scanner. All ISIS-compatible scanners are supported. 

 

4.2 Software – Operating system 

The IMiS®/Scan application works on a 32-bit or 64-bit Windows operating system.  

List of supported versions of Windows operating systems: 

• Windows 11 2H22 or later; 

• Windows 10 2H22 or later. 
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5 INSTALLATION 

IMiS®/Scan installation can be performed with a setup wizard as administrative installation or 

"silent" installation. In any case, the displayed notifications and dialog boxes are in English. 

 

5.1 Installation with the wizard 

Below is a description of the IMiS®/Scan installation procedure using the wizard.  

The installation can be performed by a user with administrator rights and in an environment,  

that meets at least the minimum installation requirements. The minimum requirements can be 

upgraded in accordance with the predicted needs. For more information see chapter Software 

– Operating System. 

 

Installation commences when launching the installation package from the file system.  
 

Example of the name of an installation package: 

IMiS.Scan.10.4.2310.Full 

 

The introductory dialog box appears: 
 

 
Image 2:  Beginning the IMiS®/Scan installation procedure 
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At any point during the installation procedure you can abort the procedure by clicking on the 

"Cancel" button. 

 

A dialog box appears in which you can either abort or continue the installation. 

All the files and settings installed in the Windows registry until then are deleted. 

 

By clicking on the "Back" button, you return to the previous installation step.  

By clicking on the "Next" button, you continue with the next step.  

 

In the next step read the terms of the license agreement carefully. If you agree with them, 

select "I accept the terms in the license agreement" and thus fully accept the license terms. 

If you do not agree with the license terms, select "I do not accept terms in the license 

agreement" and by clicking on the "Cancel" button cancel the installation procedure.  
 

 

Image 3:  Reviewing and accepting the license agreement 
 

Continue by entering the username and organization. Select whether the application will be 

installed only for the current user ("Only for me") or for all users on this computer ("Anyone 

who uses this computer"). 
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Image 4:  Customer information dialog box 
 

In the next step select between full installation ("Complete") or user-customized installation 

("Custom"). Full installation will install all the files in the installation package to the file system. 
 

 
Image 5:  Choice between complete and custom installation 

 

If you have selected the user-customized installation, a dialog box will appear in which you 

select the IMiS®/Scan modules to be installed. 
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Image 6:  Selecting the elements and location of IMiS®/Scan installation 
 

By clicking on the "Change" button, you can customize the installation location for the 

IMiS®/Scan software product. 

 

By clicking on the "Space" button, a dialog box appears containing a list of all disks, their sizes 

and free space on each disk. The disks that do not have enough free space for installation are 

marked. 

 

Image 7:  Available disk space information 
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Under the "Language Add-ons" tree branch is a list of all languages into which the user 

interface of the IMiS®/Scan application has been translated. Translations into Slovenian, 

Croatian, Bosnian and German are available. 

By removing these options, you lose the option of using the translated versions of IMiS®/Scan. 

 

Under the "Storage Connectors" tree branch are modules for connecting to archive servers.  

If you do not install these modules, you will not have the option of saving and accessing these 

servers from the IMiS®/Scan application.  

Modules are not installed only if IMiS®/Scan is being used as an independent application for 

scanning and the scanned documents are saved to a file system. 

 

Under the "Advanced Programming Interfaces" tree branch is a list of options of connecting 

the IMiS®/Scan software product to other applications.  

 

Installation is continued with the option of associating all TIFF files with the IMiS®/Scan 

application. This means that all files ending in ".tif" and ".tiff" are opened with the IMiS®/Scan 

software product. 
 

 

Image 8:  Associating all TIFF files with the IMiS®/Scan 
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In the next step select the location of the scanner's initialization files, in which the settings of 

the selected scanner are stored. 
 

 

Image 9:  Selecting the location of the scanner's initialization files 
 

The initialization files can be saved to the Windows registry or to a file system. 

 

You can choose between the following options: 

• "HKEY_CURRENT_USER" enables every user to store his or her settings separately from 

other users. Changes to the scanner settings apply only to the current user. 

• "HKEY_LOCAL_MACHINE" enables all users on this workstation to have the same 

scanner settings. Changes to the scanner settings apply to all users on this workstation. 

In order to change the scanning parameters, users must have additional rights. 

• "Off" executes the installation of the initialization file to the file system. With this method 

the rights to individual initialization files can be set more thoroughly. 
 

Example: Only one user on the workstation has the right to change scanner settings. 
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In the next step customize the displaying and adding of IMiS®/Scan shortcuts. 
 

 
Image 10:  Displaying and adding the IMiS®/Scan shortcuts 

 

You can choose between the following options: 

• "Start menu items" enables the display of the IMiS® icon in the "All Programs" menu; 

• "Desktop items" installs the IMiS® icon on the desktop; 

• "Quick Launch" displays the IMiS® icon in the quick launch taskbar. 
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The final step of the installation wizard is the confirmation of settings prior to installation by 

clicking on the "Install" button. 
 

 

Image 11:  Confirming settings prior to installation 
 

The "User Account Control" dialog box appears, by clicking on the "Install" button.  

Clicking on the "Yes" button allows the user with administrative rights the installation. 
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The installation procedure for the IMiS®/Scan software product commences;  

the progress bar shows information about the transfer of files to the appropriate locations. 
 

 
Image 12:  The installation progress bar 

 

Installation is complete when the last display box appears, which you close by clicking on the 

"Finish" button. 
 

 

Image 13:  Installation complete message 
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5.2 Administrative installation 

For specific installations you need to manually specify the location of certain files and prepare 

appropriate records in the Windows registry. 

 

IMiS®/Scan uses the following default file folders for its installation: 

• "C:\Program files\IS\IMiS" folder contains the executable file imiscan.exe with the 

corresponding language versions and the following utility libraries: 

- imispdfa.dll: module for working with the PDF file format; 

- imislsx.dll: module for connecting to the HCL Notes client; 

- IMiSW32ImagingClient.jar: interface for JAVA applications; 

- iarcli.dll: module for connecting to IMiS®/ARChive Server; 

-imisscan.<three-letter language code>: library containing a translation in the language 

indicated by the three-letter code in the file extension. 

• "C:\Windows\System32" folder contains the following utility libraries: 

- imisapi.dll: module for connecting IMiS®/Scan to another application via a C-API interface; 

-imisjapi.dll: module for connecting IMiS®/Scan to another application via a JAVA interface; 

- imislnapi.dll: module for connecting IMiS®/Scan to the HCL Notes application; 

- set of utility libraries for scanning and processing scanned documents (pix*.dll). 

• "C:\Windows\PixTran" folder contains a driver for the installed scanner, modules for 

working with various image formats, modules for various compression methods, and drivers 

for converting between different file formats. 
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5.3 Silent installation 

The IMiS®/Scan application can also be installed without user control. Installation is performed 

silently, without displaying the user interface. The installation is executed via the msiexec.exe 

utility program. This tool is a part of the Microsoft installation product and is used for 

performing various types of maintenance in applications that are installed in the Windows 

operating system. 
 

For a full list of the supported functions of the msiexec.exe program, turn to the 

Microsoft article collection:  

http://msdn.microsoft.com/en-us/library/windows/desktop/aa367449(v=vs.85).aspx 

The utility program is executed from the command bar. 

 

For a list of all parameters, turn to the Microsoft website:  

http://msdn.microsoft.com/en-us/library/windows/desktop/aa367988(v=vs.85).aspx. 

 

5.3.1 Installation procedure 

Installation can take from ten seconds to two minutes, depending on the computer speed. 
 

Example of a command bar for silent installation:  
 

C:\Windows\system32\Msiexec.exe /i IMiS.Scan.10.4.2310.Full.msi /qn 

 

Below is a command bar for the silent installation of IMiS®/Scan: 
 

 
Image 14:  Command bar for the silent installation of IMiS®/Scan 
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The table below lists the various silent installation modes: 
 

Command bar parameters Description 

/q, /qn No user interface. 

/qn+ No user interface with a modal window at the end of installation. 

/qb Basic user interface with a simple progress bar.  

The "/gb!" parameter is used to hide the "Cancel" button. 

/qr Simplified user interface without a modal window at the end of 

installation. 

/qf A full user interface with all the display boxes, a progress bar and 

error message at the end of installation. 

 

Before launching the installation of the IMiS®/Scan application, you can specify various 

parameters that are specific to this installation. Add them to the end of the command bar 

using the syntax: 
 

c:\windows\system32\msiexec.exe /i IMiS.Scan.10.4.2310.Full.msi /qn PARAMETER=VALUE 

 

The table below describes the supported command bar parameters: 
 

PARAMETER Valid Values Description 

INSTALLDIR <folder name> This attribute contains the default destination folder for 

installation files. 

(Default value = "%PROGRAMFILES%\IS\IMiS\") 

USERNAME <username> This attribute contains the username of the user performing 

the installation. (The default value is taken from system 

settings.) 

COMPANYNAME <company name> This parameter adds the company name to the installation. 

(The default value is taken from system settings.) 

REG_TIF 1 This parameter is used to inform the installation process to 

register the IMiS®/Scan application as the default viewer of 

.TIF files. (Default value=<not selected>) 
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PARAMETER Valid Values Description 

REG_TIFF 1 This parameter is used to inform the installation 

process to register the IMiS®/Scan application as 

the default viewer of .TIFF files. (Default value=<not 

selected>) 

SHORTCUT_START 1 This parameter is used to inform the installation 

process to create a shortcut in the "Programs" 

menu. 

(Default value=<not selected>) 

SHORTCUT_QUICKLAUNCH 1 This parameter is used to inform the installation 

process to create a shortcut in the quick launch 

taskbar. 

(Default value=<not selected>) 

SHORTCUT_DESKTOP 1 This parameter is used to inform the installation 

process to create a desktop shortcut. 

(Default value=<not selected>) 

INI_MAPPINGS 1,2,3 This parameter is used to inform the installation 

process to copy INI files to the Windows registry. 

1 - HKEY_CURRENT_USER 

2 - HKEY_CURRENT_MACHINE 

3 - OFF (uses INI files on the file system) 

(Default value=1) 

 

5.4 Product upgrade 

Prior to starting the upgrade, make sure that the IMiS®/Scan product is not currently active.  

This can be done by checking if the IMiS® icon  is visible in the bottom right-hand corner of 

the taskbar. If the IMiS® icon is present, close all programs into which IMiS®/Scan has been 

integrated. This terminates the operation of IMiS®/Scan. 
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When a new IMiS®/Scan version is issued, individual users must perform an installation 

procedure for the new version. This procedure is carried out with the Installation Wizard and 

matches the procedure for product installation. During the upgrade procedure, the previous 

version of the product is automatically uninstalled. 

All user settings and created documents are preserved. This is followed by the installation 

procedure for the new version. 

 

5.5 Product removal 

Prior to starting the removal, make sure that the IMiS®/Scan application is not currently 

active. This can be done by checking if the IMiS® icon  is visible in the bottom right-hand 

corner of the taskbar. If the IMiS® icon is present, close all programs into which IMiS®/Scan 

has been integrated. This terminates the operation of IMiS®/Scan. 

 

The IMiS®/Scan product is removed from the computer by selecting the button “Start”, and 

finding the program “Control Panel” and the option “Programs and Features”. 
 

 
Image 15:  Selecting the "Programs and Features" 
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By clicking on the "Uninstall" button, the "Uninstall Wizard" is launched. The removal procedure 

removes all files and settings created by the installation package. User settings and created 

documents are not deleted. 
 

 

Image 16:  Removing IMiS®/Scan 
 

5.5.1 Manual product removal 

"Manual" removal of all settings and files is also possible. Make sure that no other 

application for scanning or viewing images is installed on the computer which uses the same 

additional components as IMiS®/Scan. 

 

The removal procedure goes as follows: 

• make sure that IMiS®/Scan is not running; 

• delete the \Program Files\IS\IMiS folder and all the files and subfolders of this folder; 

• in the \Windows folder delete the files: imis.ini and setscan.ini. depending on the settings 

during installation, these files may not exist; 

• remove the following files from the \Windows\System32 folder: imisapi.dll, imislnapi, 

odma32.dll and imisjapi.dll. Depending on the settings during installation, some of these 

files may not exist; 

• in the \Windows\Prefetch folder remove all files starting with imis. 
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The procedures described below are intended for the removal of additional components.  

The same components may be used by another application, so be careful. 

 

Example: Capture Perfect 3.0.  

The procedure for removing components goes as follows: 

• remove the \Program Files\Pixtran folder and all the files in this folder; 

• remove the \Program Files\Common files\Pixtran folder and all the files in this folder; 

• remove the \Windows\Pixtran folder and all the files in this folder; 

• in the \Windows\System32 folder remove all files starting with pix. 

 

Below are instructions for removing keys from the Windows registry. Open the "Registry" 

program, find the following keys and remove them: 

• HKEY_LOCAL_MACHINE\SOFTWARE\IS; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Pixel Translations; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\IMiSClient.IMiSDocument; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\IMiScom.IMiSDocument; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0E3DB9FB-1E76-4754-B585-

0E50F4E7B4A9}; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{A7A7620F-010A-46D1-94D4-

78CC3BB09AA5}; 

• HKEY_CLASSES_ROOT\CLSID\{20BD3A45-79BE-42C4-A4C8-369D7C41B830}; 

• HKEY_CLASSES_ROOT\CLSID\{20BD3A45-79BE-42C4-A4C8-369D7C41B831}; 

• HKEY_CLASSES_ROOT\IMiSClient.IMiSSession; 

• HKEY_CLASSES_ROOT\IMiScom.IMiSSession; 

• HKEY_CURRENT_USER\Software\IS; 

• HKEY_CURRENT_USER\Software\Pixel Translations; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tif\OpenWithList\imisscan.exe; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tiff\OpenWithList\imisscan.exe; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tif\OpenWithList\imisview.exe; 

• HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tiff\OpenWithList\imisview.exe. 
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A list of records whose contents must be changed: 

• In the HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tif key replace the default value with the 

one written under the HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tif\UndoClasses key. 

• In the HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tif key replace the default value with the 

one written under the HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tif\UndoClasses key. 

• Under theHKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tif\OpenWithProgids key, remove the 

IMiS.Document value. 

• Under theHKEY_LOCAL_MACHINE\SOFTWARE\Classes\.tiff\OpenWithProgids key, remove the 

IMiS.Document value. 

  



IMiS®/ Scan & IMiS®/View Manual Version 10.4.2310 
 

2023 ©  MARGIS, Inc., All rights reserved. 40 
 

 

6 PRODUCT MANAGEMENT 

IMiS®/Scan can be managed by a root user or a user with limited rights. Changes to certain 

settings are not saved for a user with limited rights but remain the same as specified during 

the installation of IMiS®/Scan. 

 

6.1 Launching the product 

The IMiS®/Scan software product can be launched independently or as part of an application, 

to which it is connected via an API or COM interface. All IMiS®/Scan functionalities become 

available only when connected to another application. 

 

6.1.1 IMiS®/Scan as an independent product 

It is launched by clicking on the desktop icon or via the "Start" menu. Unless turned off in the 

settings, a splash screen appears briefly at start-up, containing information about the product 

version. The taskbar displays the IMiS® icon . 
 

 

Image 17:  The information about the product version 
 

When launching IMiS®/Scan, the program checks whether another IMiS®/Scan instance is 

already running. If it is, the last instance launched is automatically aborted. 
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During the launching of the application, the following is executed: 

• The default or last selected user profile, which is recorded in the Active Profile field in the 

Windows registry under the HKEY_CURRENT_USER\Software\IS\IMiS\IMiSScan key, is set.  

In the event that neither the default nor the last selected profile has been set, the 

installed default settings are used. For more information see chapter Setting the User 

Profile. 

• The scanner driver is loaded. Its name is read from the setscan.ini settings file.  

The appropriate scanner driver is loaded from the <Windows path>\PixTran folder. 

Scanner settings are read from the Windows registry, namely from the ScannerState field 

in the <path>\IMiS\IMiSScan\<profile name> key. The driver is checked if working properly. 

• The existence of a library for working with the PDF file format (imispdfa.dll) is checked. 
 

During launch a user may encounter the errors described in chapter Launch Problems. 

 

6.1.2 Integration of IMiS®/Scan into another application 

The functionality of the IMiS®/Scan product can be integrated into any Windows or JAVA 

application. 
 

Note:  The application that integrates IMiS®/Scan via a JAVA interface must be run on a Windows OS. 

 
Integration via a C-API solution is performed by invoking the supported functions in the 

imisapi.dll library. For this purpose, the imisapi.dll library must be installed in the 

C:\Windows\System32 or C:\Windows\SysWOW64 system folder. 
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Example of a code in a HCL Notes script: 
 

C-API 

… 

DeclareFunctionIMiSScanPagesLib"IMiSapi.dll" (ByvalStoreTypeAsLong, ByvalStoreInfoAsString, 

ObjIdAsString)  AsLong 

… 

result& = IMiSScanPages(Clng(IMiSObjectSty&),StoreInfo,IMiSObjectID$) 

If result& = 61523Then 

  'in case of an error in the primary protocol, try another  

  If StoreInfo2 <>""Then 

    result& = IMiSScanPages(IMiSObjectSty&,StoreInfo,IMiSObjectID$) 

  EndIf 

EndIf 

… 

 

Integration via a COM interface is performed by creating registered IMiS® COM objects and 

using their methods. Registration of IMiS® COM objects is performed during IMiS®/Scan 

installation. 

 

Example of a code in VB script: 
 

COM 

… 

SetIMiSApp =CreateObject("IMiSClient.Application") 

 

'Connect to IMiS/Arc server 

SetIMiSStorage = IMiSApp.OpenIMiSArcStorage("dev-iarc.imis.si", 16810, "Documents") 

 

'Create new IMiS document 

Set IMiSObj = IMiSStorage.CreateDocument 

 

IMiSObj.Rights = -1 

  

'Open IMiS window for modal scanning 

Rez = IMiSObj.Scan(True) 

… 
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Integration via a JAVA interface is performed by creating IMiS® JAVA objects that are 

implemented into the IMiSW32ImagingClient.jar Java library. A reference to this library must be 

included in the application into which IMiS®/Scan is being integrated. 
 

JAVA 

… 

IMiSSession session = IMiSSession.getInstance(); 

 

//Connect to IMiS/Arc server 

IMiSStorage arcStore = session.OpenIMiSARCStorage("192.168.92.2", 16810, "Documents"); 

 

'Create new IMiS document 

IMiSDocument document = arcStore.getDocument(); 

 

document.setRights(IMiSDocument.RIGHTS_ALL); 

 

'Open IMiS window for modal scanning 

document.scan(); 

… 

 

Below is an example of an integration of the IMiS®/Scan product into the HCL Notes 

application. The integration is performed partially using the C-API solution and a COM 

interface. 
 

Note:  For easier integration of IMiS®/Scan into HCL Notes the company Imaging Systems Inc. has 

created its own Notes interface. By installing the interface in your HCL Notes application, you can access 

the functionalities of IMiS®/Scan. 

 

Example:  Basic window in the HCL Notes application, into which IMiS®/Scan has been integrated. 
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Image 18:  Integracija IMiS®/Scan z aplikacijo 
 

6.2 Scanner selection 

Prior to using a scanner, you must install the suitable drivers. In the taskbar, right-click above 

the IMiS® icon ( ) and select "Select scanner" from the menu. 
 

 
Image 19:  Selecting the "Select scanner " command 

 

A dialog box for selecting a scanner appears ("Scanner Selection"). Selection of a scanner is 

tied to the scanner driver, which is why all the notifications and the user interface are in 

English. 

 

Image 20:  Selection of a scanner driver 
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Select the desired scanner from the dialog box, which becomes the default scanner until you 

select another. 

 

By clicking on the "Cancel" button, the settings are canceled and the box closes.  

 

If the desired scanner is not on the list, clicking on the "Add" button will open a window in which 

you can search for the driver location in the file system.  
 

 

Image 21:  Selecting the scanner driver location 
 

By clicking on the "Setup" button, you open a window in which you can set the 

advanced scanner options. The appearance and content of the window are adjusted to an 

individual selected scanner, which is why the display may differ from the example provided. 
 

 
Image 22:  Scanner setup 

 

"Scanner Selection..." is also accessible in the "Scan" menu in the IMiS®/Scan user 

window. 
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Image 23:  Selecting the "Select Scanner" command from the "Scan" menu 
 

  The scanner selection is recorded in the setscan.ini file, Scanner section and Driver 

field. 

You can only select one scanner, which remains active until you select another from the list or 

remove the current one from the settings.  

 

6.3 Product setup 

6.3.1 Setting the scanner via a dialog box 

After selecting the scanner, set it up. In the taskbar, right-click above the IMiS® icon ( ) and 

select "Scanner Settings" from the menu. 
 

 

Image 24:  Selecting the “Scanner Settings” command 
 

In the "Scanner settings" dialog box you can select various options:  

• paper size 

• resolution 

• brightness 

• … 
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Image 25:  Setting parameters in the "Scanner settings" dialog box 
 

By clicking on the "OK" button, all settings are saved and the dialog box closes. 

By clicking on the "Cancel" button, the dialog box closes and all the currently changed settings 

are discarded. 

By clicking on the "Defaults" button, you restore the default scanner values. 

By clicking on the "More ..." button, a dialog box appears showing the scanner manufacturer 

settings. The appearance and content of the window are adjusted to an individual selected 

scanner and may differ from the ones shown here. 
 

 

Image 26:  The scanner manufacturer settings 
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Changing individual values in the ScannerState field is not recommended, as it is intended 

solely for storing all scanner settings. The special record format may be modified in newer 

versions. If you wish to change an individual scanner setting, you can do so by changing the 

settings in the application. 

 

Scanner settings are stored in the Windows registry in the ScannerState field in the 

key of the currently selected profile. 
 

Location example: 

HKEY_CURRENT_USER\Software\IS\IMiS\IMiSScan\<profile name>\ScannerState. 

 

6.3.1.1 Description of individual scanner settings 

The values of individual settings change depending on the selected scanner. 

 

Paper size 

Under the “Paper Size” setting select the size and format of scanning. The most often scanned 

paper format is "A4" or "Letter". In the case of several different paper sizes in one document 

you can select "Scanner's Maximum". This creates a lot of empty space in the scanned 

document. 
 

 

Image 27:  Selecting the scanning size and format 
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Mode 

Under the “Mode” setting, select the scanning mode. Documents can be scanned in "Black and 

White", "256-Level Gray" or "24-Bit Color" mode.  

The "24-Bit Color" mode option will not be shown if the scanner does not support color 

scanning. Select the desired mode from the drop-down menu. 
 

 
Image 28:  Selecting the scanning mode 

 

Note:  Mode selection has a great impact on the size of the scanned document file. 

 

Resolution 

Under the “Resolution” setting select the desired scanning resolution from the drop-down 

menu. Only the resolutions supported by the selected scanner are shown. 
 

 

Image 29:  Selecting the scanning resolution 
 

Note:  Selecting high resolution has a great impact on the size of the scanned document file. 

For more information see chapter Scanning Resolution and Quality. 

  



IMiS®/ Scan & IMiS®/View Manual Version 10.4.2310 
 

2023 ©  MARGIS, Inc., All rights reserved. 50 
 

 
Patterning 

Under the “Dithering” setting select the dithering mode, where you can replace the color or 

gray with a suitable pattern of pixels of a lower color depth. The values in the drop-down menu 

depend on an individual scanner. 
 

 
Image 30:  Selecting the patterning 

 

Example:  Gray can be patterned as a chessboard of small black and white squares. 

 

Brightness 

Under the “Brightness” setting adjust the sensitivity of the scanner to non-white dots on the 

sheet. Greater brightness scans an image with fewer black or color dots. Reducing the 

brightness gives the scanned document a more "smudged" look. That is because the non-white 

dots are emphasized. 

 

Sharpness 

By setting the sharpness of a scanned document, you increase/decrease the difference 

between a light and dark dot. For better scanning of documents with poorer quality the 

correct ratio between brightness and sharpness is especially important. 
 

Example:  A darker document is scanned with smaller brightness, whereas brightness is increased for a 

lighter document. 
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Two-sided scanning (Duplex) 

If the scanner enables two-sided scanning, you can select the option "Two-sided scanning". 

When scanning individual sheets of paper, it will scan both pages. IMiS®/Scan performs two-

sided scanning of sheets only if you apply "Scan multiple pages" in the "Scan" menu. 

When performing two-sided scanning, it is recommended that you use the "Remove empty 

pages" setting, which is not enabled by all scanners. 

 

Separate scanning of odd and even pages 

IMiS®/Scan also enables two-sided scanning on one-sided scanners.  

Select the option "Separate scanning of odd and even pages". First scan the odd pages of the 

document, then turn the document around and scan the even pages. 

IMiS®/Scan will automatically insert the pages into the correct spot in the document. 

 

6.3.2 Setting options 

The IMiS®/Scan software product enables many customizations. 

In the taskbar, right-click above the IMiS® icon ( ) and select "Preferences..." from the menu. 
 

 
Image 31:  Selecting the “Preferences” command 

 

A dialog box appears showing all the settings, arranged into categories. 

By clicking on the "OK" button, you save the settings to their subkeys and fields in the Windows 

registry. 

By clicking on the "Cancel" button, all the currently changed settings are discarded. 

When reopening the settings, the user is shown by default the category which he or she 

opened when last checking the settings. 
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The setting "Preferences..." is also accessible via the "Tools" menu. 

 

6.3.2.1 Setting options – General 

When opening the "Preferences…" dialog box for the first time, the "General" category appears. 

This group contains the settings that influence the display and operation of the IMiS®/Scan 

application. 

 
Image 32:  Setting parameters in the "General" category 

 

In the "General" group the following settings options are available: 

 

Automatically run when Windows starts 

Activating the option “Automatically run when Windows starts” sets that the IMiS®/Scan 

application is launched automatically at the next Windows operating system startup and is 

present until you close it manually. 

 

Associate with <.TIF> and <.TIFF> extension 

Activating the option "Associate with <.TIF> and <.TIFF> extension" sets that all files ending in 

TIF or TIFF will be opened by the IMiS®/Scan application. 
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Close document on <ESC> key 

Activating the option “Close document on <ESC> key” sets that the document opened in 

IMiS®/Scan can also be closed by pressing the <ESC> key. 

If the document has been changed, a dialog box appears with the option of saving the changes. 

 

Save window size and position on close 

Activating the option “Save window size and position on close” sets that on exiting the 

currently open user window, the size and position of the IMiS®/Scan window are saved. The 

next time you open the document, the user window will appear in the same spot and in the 

same size. 

 

The size and position of the user window are saved in binary value to the Windows registry in 

the Image Window field, in the <path>\IMiS subkey. 

 

Hide window menu, use toolbars only 

Activating the option “Hide windows menu, use toolbars only” enables a larger view of the 

document image in the user window. Afterwards IMiS®/Scan is used solely with the commands 

in the taskbar with the menu hidden. 

The menu reappears when you disable this option. In the taskbar, right-click above the IMiS® 

icon ( ) and select "Preferences..." from the menu. 
 

 

Image 33:  Hiding window menu in the "General" category 
 

Show document windows in taskbar 

Activating the option “Show document windows in taskbar” sets that a button appears in the 

taskbar for each document open in IMiS®/Scan.  
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Close document on COM object destroy 

Activating the option “Close document on COM object destroy” sets that a document, which is 

shown in IMiS®/Scan and opened via Windows COM technology, is automatically closed when 

the COM object to which this document was connected is destroyed. 

 

Hide splash screen on startup 

Activating the option “Hide splash screen on startup” disables displaying of the splash screen 

when launching the IMiS®/Scan application is disabled. 

The settings are saved in binary form to the Windows registry in the Preferences field 

in the <path>\IMiS subkey. 

 

Enable logging 

In the "Log options" group you can specify the path of the text file in which you wish to log the 

operation of IMiS®/Scan. Select the operations level to log in the "Level" drop-down menu. 

 

You can choose between the logging of critical errors only and the detailed logging of 

operation. 

 

Image 34:  Selecting the operations level in the "General" category 
 

The name of the logging file is imis.log. The option "Enable operations log" is recorded 

in the Windows registry in the LogEnable binary field in the <path>\IMiS/IMiSScan subkey.  

In this subkey the logging level is entered in the LogLevel text field. The directory in which the 

log is saved in recorded in the Windows registry in the LogDir text field in the 

<path>\IMiS/IMiSScan subkey. 
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The <path>\IMiS/IMiSScan subkey also contains the LogSize numeric field, which records the size 

of an individual log file. The default file size is 1Mb. When this size is exceeded, all the log files are 

rotated. The rotation cycle is recorded in the same subkey in the LogCount numeric field. 

The default rotation value is 10. 

 
6.3.2.2 Setting options – Documents 

The "Documents" category from the "Preferences" dialog box is used when selecting the file 

format for new documents and when selecting the settings for printing newly-added pages.  

New pages can be created by scanning a document or by selecting "Paste" via the clipboard. 

The contents in the clipboard are saved in the format selected in the settings. 
 

 
Image 35:  Setting parameters in the "Documents" category 

 

In the "File format" group you can select a format for saving documents: 

• "Multi-page TIFF file (*.tif)" for creating multi-page TIFF documents. 

• "Adobe PDF file (*.pdf)" for creating image documents in the PDF/A-1b standard. 

 

In the "Compression for new pages" group select the compression method for each type of 

color image. The compression modes available depend on the selected format for saving. 

By changing the format, you also change the compression mode for new pages. 
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When scanning black-and-white documents with the IMiS®/Scan application, it is 

recommended that you select the saving of TIFF files with G4 compression. For the scanning of 

color documents, it is recommended that you use a Wang-compatible JPEG format. 

For simpler transfer of scanned documents between applications and operating 

systems it is recommended that you select the saving in PDF file format with the default 

compression method settings. See also chapter File compression and size. 

 

Warning:  Changing the saving mode does not affect the currently open documents, but only those which 

will be created after the "Options" dialog box is closed. 
 

Settings are recorded in binary form in the currently selected profile in the Windows 

registry in the Preferences field in the <path>\IMiS\IMiSScan\<profile name> subkey. 

 

6.3.2.3 Setting options – Annotations 

The "Annotations" category from the "Preferences" dialog box contains certain settings for 

bookmarks in TIFF documents. 
 

 

Image 36:  Setting parameters in the "Annotations" category 
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In the "Annotations format" group select one of the formats for saving annotations: 

• "Pixel Translations format" is compatible with viewers that use image viewing tools by 

EMC (e.g. QuickScan). 

• "Wang compatible format" is compatible with the "Imaging for Windows" viewer. 
 

The settings are saved in binary form in the Windows registry in the Preferences field in the 

<path>\IMiS subkey. 

 

In the "Annotations options" group the following settings options are available: 
 

Show annotation tools in all mouse modes 

Activating the option “Show annotation tools in all mouse modes” sets that the annotations 

group is shown in the user window in all operation modes, i.e. even when the annotations mode 

is not turned on. 

 

Enable sticky annotation tool move 

Activating the option “Enable sticky annotation tool mode” sets that the currently selected 

annotation remains active even after being placed in the document and can be used by the user 

several times. 
 

The annotation can also be preserved by clicking on the "Preserve" button, which is 

located in the "Annotations" group in the user window.  

 

Enable custom annotation mouse mode 

Activating the option “Enable custom annotation mouse move” enables easier placement of 

annotations in a document. When this setting is selected, the user annotation is placed on the 

mouse cursor and can thus be placed in the desired spot in the document. Otherwise the user 

annotation is placed in the spot of its creation. 
 

All of the above-mentioned settings are saved in binary form in the Windows registry in the 

Preferences field in the <path>\IMiS subkey. 
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The "Default Settings" group is used for setting the default values of annotation tools. 

 
Text font 

Under the “Text font” setting, define the default font for text annotations. 

 

Hilite color 

Under the “Hilite color” setting, define the default color of the annotation tool for highlighting 

text. 

 

Redaction color 

Under the “Redaction color” setting, define the default color of the annotation tool for 

redaction, which covers the selected part of the text. 

 

Line thickness 

Under the “Line thickness” setting, define the thickness of the lines of annotation tools 

("Arrow", "Line", "Rectangle", "Ellipse" and "Broken Line"). 

 

These values can also be changed in the user window in the "Annotations" group or 

when placing an annotation in a document. 

 

The settings are saved in binary form in the Windows registry in the DefaultAnnot field in the 

<path>\IMiS subkey. 

 

In the "Stamp location" group you can specify the location of the default stamp. 

IMiS®/Scan only enables stamps saved in BMP format. The path to the image is saved in the 

Windows registry in the StampPath field in the <path>\IMiS subkey. 
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6.3.2.4 Setting options – Scan 

The "Scan" category from the "Preferences" dialog box enables the setting of the operation of 

IMiS®/Scan during scanning. 
 

 

Image 37:  Setting parameters in the "Scan" category 
 

In the "Scan options" group the following options are available: 
 

Automatically start scanning in new documents 

By activating the option “Automatically start scanning in new documents”, IMiS®/Scan 

automatically begins the scanning procedure when a new user window is created. Scanning 

does not commence if the scanner has not been selected or connected. 

 

Enable "Save & close" button when ADF is empty 

Activating the option “Enable ‘Save & Close’ button when ADF is empty” enables the display of 

the “Save and close” button in the “Scan status” dialog box, thus speeding up the scanning 

procedure. By clicking on the "Save and close" button in the dialog box, you enable a faster 

scanning procedure, since it facilitates the saving and closing of a scanned document.  

This option is recommended for the mass capture of documents. 
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Show “Scan status” dialog when scanning single page 

In the case of default settings, the "Scan" dialog box appears only when scanning multiple 

pages. By selecting the option “Show ‘Scan status’ dialog when scanning single page”, you 

activate the box for the scanning of individual pages too. 
 

 
Image 38:  Scanning of individual pages dialog box 

 

In the "Insert mode" group you can set the default mode of inserting new pages into a 

document. The two options are:  

• "Insert" a new scanned page after the previous one. 

• "Overwrite". Current page and all of the scanned pages below the mouse cursor are 

overwritten with new one. 
 

The setting is saved in binary form in the Windows registry in the Preferences field in 

the <path>\IMiS subkey. 
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By clicking on the "Configure" button, you can select and configure the image processing filters 

in the "Image processing" group. This setting is present only in the IMiS®/Scan+ client version. 
 

 

Image 39:  Setting the image processing filters in the "Scan" category 
 

Clicking the "Disable" button in the "Scanner" group disables the use of the scanner or 

deactivates it. This functionality is intended primarily for laptop users who occasionally work 

from home. After deactivating the scanner, the driver dialogs are not displayed while using the 

application because the scanner is not present. When returning to work, they will have the 

option of reactivating the scanner by clicking the button “Enable”, which replaces the button 

“Disable” on deactivation. 

 

If a scanner is not connected to the workstation, you can remove the driver record from 

IMiS®/Scan in the "Scanner" group by clicking on the "Remove" button. If the driver record is 

removed, the scanner must be reselected and reconfigured. 

 

Example:  Scanner repair. If you do not remove the driver record, the user receives frequent notifications 

that the scanner is not connected, which can be disrupting. 

Remove the Driver field from the Setscan.ini file in the Scanner section. 

The same procedure is performed in the mapped file in the Windows registry. 
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6.3.2.5 Setting options – View 

In the "View" category set the default values for document display. 
 

 

Image 40:  Setting parameters in the "View" category 
 

In the "View options" group you can set: 
 

View settings apply to all pages 

Activating the option “View settings apply to all pages” sets that the actions (rotation, scale, 

and showing of grays) which are carried out on the current page are carried out on all other 

pages as well. 

You can also turn on/off the setting for all pages in the user window menu, in the "View" 

menu by clicking "Apply to all". This applies only to the currently open window.  

For a newly-opened user window the default setting once again applies. 

 

Enable enhanced image rendering 

Activating the option “Enable enhanced image rendering” enables an enhanced image display. 

Scanned documents are easier to read when black-and-white scanned documents, content is 

converted into shades of gray. In the case of gray and color scanned documents it uses the 

smoothing algorithm for an enhanced display. 
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 This setting can also be enabled or disabled with the command “Enhance” in the “View” 

menu or via the popup menu on the document page. The selection applies only to the currently 

open window. For a newly opened user window the default setting once again applies. 

 
Show document´s thumbnails 

In the user window this option is used for turning the showing of document thumbnails on/off.  

By clicking on the selected thumbnail, you move to the viewing of the selected page. 

 

Show even thumbnail per row 

Activating the option “Show even thumbnails per row” shows an even number of thumbnails in 

the left part of the central window. 

Selecting this option is recommended when viewing two-sided scanned documents. 

 

Keep view position on page selection 

Activating the option “Keep view position on page selection” sets that the view for the selected 

document pages is always the same (e.g. always shows the bottom part of the page). 

 

Keep region when changing pages 

Activating the option “Keep region when changing pages” preserves a specific area on the page 

even when switching pages. 
 

Example:  In the case of manual object recognition (OCR), when data is always located in the same 

section of the page. For more information see chapter Area Selection. 

 

Show large toolbar icons 

By activating the option “Show large toolbar icons”, larger icons are shown instead of the 

default icons in the toolbar. 
 

Example:  On screens with a resolution of over 1024x768 icons in the user window look smaller. Hence it 

is recommended that you select this option. 
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Image 41:  Showing large toolbar icons 
 

The selected settings take effect as soon as they are confirmed in the dialog box. 

 

In the "Page scale" group you can select among different page display sizes in the user window: 

• "View actual size": one pixel in the scanned document is shown with one pixel on the 

screen. 

• "Show whole page": the entire page of the document is reduced/enlarged so that the 

entire page of the document is visible in the user window and the entire image viewing 

area is filled. 

• "Fit to window height": the entire page of the document is reduced/enlarged so that the 

entire height of the image viewing area in the user window is filled. 

• "Fit to window width": the entire page of the document is reduced/enlarged so that the 

entire width of the image viewing area in the user window is filled. 
 

The most common choices are: "Show whole page" or "Fit to window width". 

 

In the "Thumbnail size" group you can select among different sizes of document thumbnails: 

• "Tiny" 

• “Small” 

• “Medium” (default) 

• “Large”. 

 

The change in settings will take effect only in a newly-opened user window. 

To change the thumbnail size in the currently opened user window you can select the "Tools" 

menu in the user window menu and then the desired size in the "Thumbnail size" submenu. 
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Right-click on the page thumbnails. A menu appears in which you can select the desired 

thumbnail size in the "Thumbnail size" submenu. For more information see chapter Thumbnails. 
 

The settings in the "View" category are saved in binary form in the Windows registry 

in the Preferences field in the <path>\IMiS subkey. 

 

6.3.2.6 Setting options – Export 

In the "Export" category set the default values for: 

• sending a document by email; 

• exporting a document to a file system; 

• cases when IMiS®/Scan is activated via another application and the export document 

functionality is used. 
 

 
Image 42:  Setting parameters in the "Export" category 
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In the "File format" group, set the file format in which the copy of the document will be 

exported. Available options are: 

• "Current format". The document can be kept in its existing format. 

• "Multipage TIFF file (*.tif)". 

• “Adobe PDF file (*.pdf)”. 

 

If the selected format differs from the existing one, conversion to the selected format is 

performed prior to exporting. 

 

  The value of the selected format of saving is saved in hexadecimal form in the 

Windows registry in the ExportFormat field in the <path>\IMiS subkey. The value for the existing 

format is -1, for the TIFF format the value is 3000 (hexadecimally), and for the PDF format 

150000 (hexadecimally). 

 

The following settings can be selected in the "Options" group: 
 

Export original signed documents 

With the option “Export original signed documents” set whether digitally signed documents are 

exported as copies or as a signed original. Based on the merge settings, the copy of the 

document will contain merged annotations or an digital signature. 

 

  The setting is saved in binary form in the Windows registry in the ExportOriginal field  

in the <path>\IMiS subkey. 
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Save page rotation/mirror 

By activating the option “Save page rotation/mirror”, rotated/mirrored pages are saved on 

export. 
 

  The setting is saved in binary form in the Windows registry in the ExportRotation 

field in the <path>\IMiS subkey. 

 

Hide export options dialog 

With the option “Hide export options dialog” select whether a dialog box should appear before 

exporting a document. If you do not wish the dialog box to appear, the default settings are 

applied. If the hide function is not activated, you can still change the default settings prior to 

export. 
 

  The setting is saved in binary form in the Windows registry in the Preferences field in 

the <path>\IMiS subkey. 

 

In the "Merge settings" group select which annotations you wish to merge during export. 

Annotations which are not marked to be merged are removed from the document in the 

document copy. Available options are: 

• "Text annotations". 

• "Highlight annotations". 

• “Popup annotations”. 

• “Image annotations”. 

• “Document redactions”. 

• “Visible signatures”. 
 

  The settings are saved in binary form in the Windows registry in the Preferences 

field in the <path>\IMiS subkey. 
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6.3.2.7 Setting options – Printing 

In the "Print" category set the default values for document printing. 
 

 
Image 43:  Setting parameters in the "Print" category 

 

In the "Print scale" group you can select one of the following options from the drop-down menu: 

• "Actual size": adjusts the image size so that one centimeter in the image equals one 

centimeter in the printout. The scanned document is printed in the same format as it was 

scanned. If this option is selected, the document is not enlarged or reduced during printing.  

In the event that the scanned document format is bigger than the paper the document will 

be printed on, only a part of the scanned document is printed. 

• "Fit to paper": adjusts the image so that it fills as much of the paper surface as possible. 

A default option, which is useful when the scanned document format differs from the format 

of the paper on which you will be printing the scanned document. This option makes sure 

that the scanned document fills the entire printed page. 

• "Actual pixels": the printer prints a pixel for every pixel in the image. This printing mode 

ensures that the document resolution is preserved on paper. During printing, individual 

pixels of the image are not interpolated. Documents scanned in a resolution smaller than 

the printer resolution (600 dpi) will be reduced on paper, otherwise they will be enlarged.  

This option is most useful for printing photographs, since the image quality is preserved. 
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  The settings are saved in binary form in the Windows registry in the Preferences 

field in the <path>\IMiS subkey. 

 

6.3.2.8 Setting options – Signature 

In the "Signature" category set the default values for digital signing of documents. 
 

 
Image 44:  Setting parameters in the "Signature" category 

 

In the "Select certificate" group first select the digital certificate with which you will be signing 

documents. Select the appropriate digital certificate from the drop-down menu. 

 

In the "Signature options" group choose among the options: 
 

Document is signed with default signature on each save 

With the option “Document is signed with default signature on each save” set the automatic 

signing of every document when saving it. 

 

Prompt if document is not signed 

Activating the option “Prompt if document is not signed” sets a reminder to warn you when 

saving a document which has not been digitally signed. 
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Image 45:  Warning when a document has not been signed 

 

Prompt if digital signatures may become invalid 

Activating the option “Prompt if digital signatures may become invalid” sets a reminder to warn 

you of an invalid signature when editing an existing digitally signed document. Should you wish 

to edit an existing digitally signed document and could invalidate the existing digital signatures 

by doing so, a notification appears. 

 

 

Image 46:  Warning when digital signatures may become invalid 
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Hide signature information pane 

Activating the option “Hide signature information panel” sets that the pane containing the 

digital signature status is not visible. 
 

 
Image 47:  Hiding the information pane 

 

In the "Signature reason" group prepare the most common reasons for signatures in advance. 

The signature reason is added to the digital signature and is recorded into the document 

together with the digital certificate. The entered reason can be removed by selecting the 

reason and pressing the "Ctrl+Delete" key combination. 

 

6.4 Product shutdown 

The IMiS®/Scan software product can be shut down in two ways: 

• from the “File” menu by selecting the "Exit" option. 
 

 
Image 48:  Selecting IMiS®/Scan shut down from the menu in the command bar 
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• in the “Tools” menu, right-click above the IMiS® icon ( ) and select "Exit" from the menu. 

 
Image 49:  Selecting IMiS®/Scan shut down from the menu in the toolbar 

 

IMiS®/Scan can be closed from the "Tools" menu only if it was launched as an independent 

application. Otherwise the "Exit" option is not enabled and is controlled by the application to 

which IMiS®/Scan is connected. 
 

Regardless of the way IMiS®/Scan was launched, it can be closed by right-clicking the 

IMiS® icon in the taskbar, which invokes the menu, and then pressing the "Alt+F4" keys.  

  



IMiS®/ Scan & IMiS®/View Manual Version 10.4.2310 
 

2023 ©  MARGIS, Inc., All rights reserved. 73 
 

 

7 DOCUMENT MANAGEMENT 

7.1 New document 

With IMiS®/Scan you can create a new document in several ways, depending on how 

IMiS®/Scan has been activated. 

 

Creating a new document from the toolbar menu 

By clicking the "New document" option, which is located in the toolbar menu. 

For more information see chapter Launching the product. 

 

 

Image 50:  Creating a new document from the “Tools” menu  
 

In this case the user has the right to execute any action in IMiS®/Scan.  

The document is saved to the file system. 
 

  When a temporary file cannot be created, the error message appears: 

"Error <DOCIO_UNKNOWN> when opening document" 
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Creating a new document when IMiS®/Scan is part of another application 

The first step in creating a new document depends on the application into which IMiS®/Scan is 

integrated. It is usually the "Scan" button. 

 

The rights to execute various actions in IMiS®/Scan can be restricted and controlled via the 

application into which IMiS®/Scan is integrated. The document is saved to the IMiS®/ARChive 

Server. 
 

You can also open a new document from the currently open user window by clicking the 

"New" option in the "File" menu. 
 

If the IMiS®/Scan user window is already open, you can click the "New" icon  in the 

toolbar to open a new document. 

 

  When creating a new document on IMiS®/ARChive Server, these two notifications 

may appear: 

• DOCIO_ENGSTAR: the iarcio.dll library in the <Windows path>\System32 folder does not 

exist or an error has occurred when loading the library. 

 
• DOCIO_NOCONNECT: connection to the archive server is not possible or an error has 

occurred when establishing a server session. A more detailed description of the cause of 

the error can be found in the iarcio.txt file. 

 
In the case of an error or incorrect transfer of the save location parameters, the following 

error message appears: "Incorrect document location information". The user window closes 

and IMiS®/Scan returns the DOCIO_ENGSTART error. 

The user reopens the IMiS®/Scan window and repeats the scanning. If the scanning is again 

unsuccessful, it is recommended that you send a request to support@imis.eu, describing the 

error. 
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7.2 Description of a user window for creating a new document 
 

 
Image 51:  Creating a new document 

 

In the case of default settings, the user window of a new document is divided into: 

• Title bar containing the name of the scanned document. Until the document has been 

saved, it is entitled "New document". On the right side of the title bar are three standard 

buttons for window management (exit the program, hide the window and 

maximize/minimize the window). 

• A toolbar in which you can activate the desired command with one click on the 

appropriate button. The icons on the buttons symbolize the meaning of an individual 

button. If you hold the mouse cursor above an individual icon for a few seconds, a tooltip 

appears, describing the tool. The toolbar can be hidden, which gives you more room for 

viewing documents. 

For more information see chapter Toolbar. 
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A menu with all the options. Some of the menu options have their own keyboard shortcut 

with the combination of "Ctrl key and the underlined letter in the menu name". 

For more information see chapter Setting Options – General. 
 

Example:  To create a new document press "Ctrl+n". The menu can be hidden in the dialog box in 

the "General" category. 
 

• The left part of the central window is intended for viewing all document pages.  

Using the thumbnails of pages, you can quickly browse through the document, select 

pages, arrange the order etc. This part of the window can also be hidden.  

For more information see chapter Thumbnails. 

• The central part of the window is intended for displaying the currently selected 

document page. 

• The right part of the central window is hidden by default. This pane contains various 

IMiS®/Scan settings and actions, divided into categories, and shows the more important 

information about the current page. The right pane is shown by clicking the left split bar, 

with which you can also widen or narrow the right pane. 

• The status bar in the bottom of the screen shows additional information: current page, 

writing mode, writing format, scale. For more information see chapter  

Description of the User Window of an Existing Document. 

 

7.3 Adding pages 

New document pages are created by: 

• scanning them; 

• pasting them to the current document from the clipboard. 

 

Pages are inserted in two ways: 

• "Insert":  inserts new pages before or after the current page, depending on the position 

of the mouse cursor. For more information see chapter Thumbnails. 

• "Overwrite":  overwrites old pages with new ones from the currently selected page 

onwards. 
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The current insertion mode is visible in the status bar. 
 

 
Image 52:  Viewing insertion mode 

 

The page insertion mode can be changed in the "Page" menu by selecting the "Insert mode" and 

“Insert” submenu or by pressing the "Insert" key. The thus changed settings only apply to the 

current user window. 

 
Image 53:  Selecting the "Insert" command from the "Insert mode" submenu 

 

If you wish to change the default setting for the insertion mode, you can do so in the dialog box 

under the "Scan" category. For more information see chapter Setting options – Scan. 

 

Before adding new pages into a blank document, select the file format for saving the document. 

This setting is selected in the right pane in the "Document Settings" category by clicking on the 

"Basic" tab in the "File format" group. If the right pane is not visible, open it by clicking on the 

right split bar. You can choose between the PDF or TIFF file format. 

For more information see chapter File compression and size. 

 

You cannot change the file format of already scanned documents. The installed default 

setting is the TIFF format. 
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7.3.1 Scanning 

Scanning is performed with a connected scanner. Before using IMiS®/Scan for the first time, 

you must select the scanner in the "Scan/Select Scanner" menu. The same procedure is 

performed when replacing the scanner. For more information see chapter Scanner selection. 

Scanner settings are checked and changed in the dialog box. 

For more information see chapter Setting a scanner via dialog box. 

 
7.3.1.1 Basic scanner setup 

If the right pane is not visible in the user window, you can open it by clicking on the split bar in 

the right window margin. By clicking on the "Document Settings" group, the scanning settings 

appear. 

 

Image 54:  Selecting the settings in the right pane "Document settings" 
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The showing of desired settings is enabled with the "Scanner settings" option in the 

"Scan" menu. 

 

The showing of the desired settings is enabled by clicking on the "Change the scanner 

settings" toolbar icon.  

 

For documents which do not contain images we recommend scanning in black-and-

white mode with a resolution of 300 dpi. For more information see chapter Scanning 

resolution and quality. 

 
 
If the scanned document is poorly readable, we recommend that you repeat the scan 

with changed brightness and sharpness settings. If even these settings do not result 

in a satisfactory quality of scanned documents, scan the document in gray mode. 
 

 
Image 55:  Setting the quality of scanned documents 
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7.3.1.2 Advanced scanner setup 

In addition to the basic scanning settings, the tab "Advanced" contains other scanner settings: 

compression methods based on the color depth of scanning, separate scanning of odd and 

even pages, patterns, internal blank page removal and the "More scanner options" button. 
 

 
Image 56:  Selecting advanced scanning settings in the tab “Advanced” 

 
Compression settings 

In the "Advanced" tab in the "Compression settings" group you have the option of selecting the 

compression mode for scanned documents when saving them. Compression significantly 

reduces the quantity of data to be saved. Different methods are available for each color depth, 

depending on the file format. For more information see chapter Setting options – Document. 
 

  By clicking on the "Save" button, the settings are saved in the Windows registry in 

the Preferences field in the <path>\IMiS\IMiSScan\<profile name> subkey. 
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Dither 

By opening the menu, you can select the pattern from the menu and replace the color or gray 

with a suitable pattern of pixels of a lower color depth. 
 

 
Image 57:  Setting pattern 

 

Options 

Selecting the option "Separate scanning of odd and even pages", you first scan the odd pages of 

the document, then turn the document around and scan the even pages. 

 

By selecting the option “Enable internal blank page removal”, we activate the mechanism for 

the detection and removal of blank pages at the application level. This feature comes in handy 

when the scanner does not natively enable the blank page removal feature. 

 

The user can influence blank page detection through the setting “Threshold”. The threshold 

value is 10 by default. Increasing this value captures a wider range of pages considered blank, 

while decreasing this value reduces the range. 

 

The recommended setup values for the threshold for blank black-and-white A4 pages with a 

resolution of 300dpi with suitable scanner settings are: 

• Pristine white: 0-10 

• Dirty white: 10-20 

• Very dirty white: 20-40. 
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When defining the setup values of the blank page detection threshold, it helps to first scan a 

sample of different blank pages. In the log file that is located in the directory “%TEMP%” by 

default the user looks for the entries “<IPUtils.IsBlank>” with the calculated values of the blank 

page detection algorithm. Based on these, the user selects the appropriate value. 
 

 
Image 58:  Example of the value of the blank page detection algorithm for a non-blank page 

 

 
Image 59:  Example of the value of the blank page detection algorithm for a blank page 

 

By clicking the "More scanner options" button, a new dialog box appears containing advanced 

scanner settings. Not all scanners support this functionality. The values that are available in 

the settings depend on the type of scanner. 
 

 

Image 60:  Advanced scanner settings 
 

If you wish to keep the changed settings for your next scan, click on the "Save" button. 

 

By clicking on the "Cancel" button, all changes are discarded. The settings remain at their 

previous values. For more information see chapter Description of individual scanner settings. 

 

  The settings are saved in the Windows registry in the ScannerState value in the 

<path>\IMiS\IMiSScan\<profile name> subkey. 
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7.3.1.3 Setting the user profile 

For different types of documents, such as black-and-white, color, various paper sizes and the 

like, you need optimum scanner settings.  

Every time you change the document type you have to change at least three different settings,  

on average. In order to avoid the constant changing of values, you can arrange the settings into 

groups and save them to the profile. Profile settings are located in the right pane under the 

"Document Settings" category in the "Profile" tab. 
 

 

Image 61:  Setting the user profile 
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Settings 

When installed, IMiS®/Scan contains only one profile with the default values. The default profile 

can be changed or a new one can be added. By entering a new name in the "Profile name" field, 

you create a new profile. 
 

  The profile is saved in the Windows registry as the <path>\IMiS\IMiSScan\<profile 

name> key.  

A longer profile description is entered in the "Profile Description" field, which is saved in the 

Windows registry in the ProfileDescription field in the <path>\IMiS\IMiSScan\<profile name> 

subkey. 

 

Options 

In the "Options" group you can choose between two statuses: 

• "Global":  By confirming this option, you enable the profile to be visible to all users on this 

computer. The entire profile is recorded in the Windows registry in the 

HKEY_LOCAL_MACHINE\Software\IS\IMiS\IMiSScan\<profile name> key.  

You must have the rights for writing in this key. 

• "Default":  By selecting this setting, you mark the current profile as default. Only one 

profile can be the default one. When saving it, the value is recorded in binary form in the 

Windows registry in the DefaultProfile field in the <path>\IMiS\IMiSScan\<profile name> 

subkey.  

Prior to this, the previous default profile is stripped of its "Default" status. The "Default" 

status takes effect when launching the IMiS®/Scan application. 

 

By clicking on the "Save" button, all settings are saved in the Windows registry in the above-

mentioned fields and keys. 

If you wish to remove an entire profile from IMiS®/Scan, click on the "Delete" button.  

If you have only one profile in IMiS®/Scan, the "Delete" button will be disabled, since one profile 

must be set at all times. 
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7.3.1.3.1 Selecting a user profile 

The profile you have prepared can be selected from the drop-down menu under the "Document 

Settings" category in the right pane. When changing the profile, all settings in this category 

change to the values of the saved profile. The name of the newly-selected profile is saved in the 

Windows registry in the Active Profile field in the 

HKEY_CURRENT_USER\Software\IS\IMiS\IMiSScan key. The name of the last-selected profile is 

applied when launching the IMiS®/Scan application. 

For more information see chapter Launching the product. 

 

7.3.1.4 Scanning procedure 

Depending on the scanning mode, only one page can be captured in a document or all the pages 

which are placed on the scanner feeder simultaneously. 

 

7.3.1.4.1 Scanning single page 

By clicking the option "Scan page" in the "Scan" menu, you begin the process of capturing one 

page. 

 
Image 62:  Selecting "Scan page" command from the menu 

 

The scanning of one page is started by clicking on the "Scan page" icon  in the 

toolbar. A sheet of paper can be inserted into the automatic feeder or placed onto the 

scanner flatbed. If the paper is placed onto the automatic feeder, the scanner will pull it in using 

its sensor and capture only one page of the paper, even if the two-sided scanning setting is 

turned on. 

For more information see chapter Setting the scanner via a dialog box. 
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In the event that several sheets of paper are placed onto the feeder, only one page is scanned 

and the scanner automatically prepares a new sheet of paper for scanning. The procedure of 

scanning one page can be repeated, or scanning can be finished. 

 

7.3.1.4.2 Scanning multiple pages 

By clicking on the "Scan batch" option in the "Scan" menu, you begin the process of capturing 

multiple pages. 

 
Image 63:  Selecting "Scan batch" command from the menu 

 

The scanning of multiple pages is started by clicking on the "Scan batch" icon  in 

the toolbar. The scanner starts feeding paper only when paper is loaded into the 

automatic feeder. For each scanned sheet of paper, an image is created in the document.  

When selecting two-sided scanning, two images are created in the document for each scanned 

sheet of paper. For more information see chapter Setting the scanner via a dialog box. 

 

The presence of the scanner is automatically checked prior to initiating the scanning 

procedure. If communication with the scanner is not possible or the scanner driver is not 

loaded, an error message appears. 
 

 

Image 64:  Scanner communication failure 
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When this error appears, it is recommended that you reselect the scanner and check the 

scanner status when it is turned on, turned off, connected to the computer and the like. 

 

When scanning, the "Scan" status window appears. When scanning single page, this window 

appears only if this option is turned on in the settings. 

For more information see chapter Setting options – Scan. 
 

 

Image 65:  Showing the scan status 
 

The "Scan" status window shows the current status of paper feeding. 
 

 

Image 66:  Showing the status after canceling the scan 
 

After finishing the scanning of all sheets in the feeder, scanning stops with a notification in the 

status window: "ADF is empty". You can resume scanning by inserting new documents for 

scanning in the feeder or by placing a new document for scanning onto the flatbed.  

Before doing so, you must select the "Continue on flatbed " option. The scanning procedure is 

continued by clicking on the "Continue" button. Scanning can be stopped by clicking on the 

"Stop" button. 
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During scanning the scanner may pull the paper from the feeder incorrectly. In this case the 

paper in the scanner gets "crumpled" and scanning is stopped with the notification:  

"Paper jammed in scanner". 
 

 
Image 67:  "Paper jammed in scanner" notification 

 

The paper must be physically removed from the scanner and the scanning procedure 

restarted. Sometimes it is also necessary to restart the scanner and IMiS®/Scan. Make sure 

that the paper does not have any folded edges and is placed straight between the guides. 

For "crumpled" paper we recommend scanning on the flatbed. 

 

If you have selected the "Enable Save & Close button when ADF is empty" option in the "Scan" 

category in the “Preferences” dialog box, then after scanning all the sheets from the feeder the 

"Save and Close" button appears. 

By clicking it, you can quickly and easily save and close the scanned document. 

For more information see chapter Setting options – Scan and Saving and closing a document. 
 

 

Image 68:  Selecting "Save & Close" command 
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7.3.2 Copying to the Clipboard 

Individual pages in the document can be copied to the clipboard by clicking the "Copy" option, 

located in the "Edit" menu. 

 
Image 69:  Selecting "Copy" command from the “Edit” menu 

 

You can also copy pages to the clipboard by clicking on the "Copy" icon  in the 

toolbar. An alternative option is via the "Tools" menu in the right thumbnail pane, 

where you select "Copy", or with the "Ctrl+C" or "Ctrl+Insert" key combination. 

 

If only a single page is copied to the clipboard, this page can be pasted to any other application 

which enables the editing of image files (e.g. MS Paint, PhotoShop, etc.). 

 

If you wish to remove the selected pages from the document after copying them, select "Cut", 

which is located in the "Edit" menu. 
 

The cutting of pages to the clipboard can be performed by clicking the "Cut" icon  

in the toolbar. An alternative option is via the "Tools" menu in the right thumbnail pane, 

where you select "Cut", or with the "Ctrl+X" or "Shift+Delete" key combination. 
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7.3.3 Pasting from the Clipboard 

Contents can be added to a document via the clipboard from other applications as well or 

within the IMiS®/Scan application from one document into another. The "Paste" option is 

located in the "Edit" menu. 

 
Image 70:  Selecting "Paste" command from the "Edit" menu 

 

The adding of images from the clipboard is performed by clicking the "Paste" icon   

in the toolbar. An alternative option is via the "Tools" menu in the right thumbnail pane, 

where you select "Paste", or with the "Ctrl+V" or "Shift+Insert" key combination. 

 

7.3.3.1 Adding contents from other Windows applications 

If a Windows application enables the copying of images to the clipboard, these images can be 

added to a document open in the IMiS®/Scan application. You can add only one image or page 

at a time. Before you can add content with the "Paste" option, you need to copy it to the 

clipboard using the "Copy" option. For more information see chapter Table of valid 

compressions for different types of files. 

 

Warning:  Transferring images via the clipboard affects the quality of the newly created image in 

IMiS®/Scan. For 24-bit image color depths we recommend the ZIP compression mode setting. 

This compression mode does not affect the image quality. 
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If the clipboard does not contain an image or contains other content, an error message 

appears when transferring it to IMiS®/Scan. 

 

7.4 Scrolling through a document 

A document may have several pages. The thumbnail pane is used for scrolling through the 

pages. By clicking on the selected thumbnail, an image of that page appears in the central part. 

You can switch pages by clicking on the "Next" and "Previous" options in the "Page" menu. 

 
Image 71:  Selecting "Previous" or “Next” command from the "Page" menu 

 

"Page Down" or "Page Up" keys.  

You jump to a specific page by clicking on the "Select page" option. A dialog box appears 

in which you enter the desired page number. 

"Ctrl+G" key combination. 

 

You can continuously scroll through a document by holding the up or down arrow keys. 
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7.4.1 Thumbnails 

Thumbnails in the right pane can be hidden with a setting in the "Tools" menu by selecting the 

"Thumbnails " option. 

 
Image 72:  Selecting "Thumbnails” command from the "Tools" menu 

 

Thumbnails are hidden by right-clicking on the thumbnail pane; when the "Tools" menu 

appears, select the "Thumbnails" option. 

"Ctrl+T" key combination. 

 

Note:  The same method is used to display them again. 

 

The size of the thumbnails is selected in the "Thumbnail size" drop-down menu in the "Tools" 

menu. 

 
Image 73:  Selecting "Thumbnail Size” command from the "Tools" menu 

 

By right-clicking on the thumbnail pane, the "Tools" menu appears. Click on the 

"Thumbnail size" drop-down menu and select the desired thumbnail size. 

This size setting applies only to the current user window; you can set the thumbnail size for all 

new user windows in the settings. For more information see chapter Setting options – View. 
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7.5 Deleting pages 

The document has to be in edit mode. Mark the page(s) in the thumbnail pane that you wish to 

remove from the document and select "Delete" in the "Edit" menu.  
 

 
Image 74:  Selecting "Delete" command from the "Edit" menu 

 

The following dialog box appears: 
 

 

Image 75:  Deleting page(s) notification 
 

By clicking on the "Yes" button, the selected page(s) will be removed from the document.  

If the document has only one page, the page cannot be deleted. 
 

Warning: If the document has only one page, the page cannot be deleted. 

 

Pages can be deleted by clicking on the "Delete" icon  in the toolbar or with the 

"Del" key. 

  



IMiS®/ Scan & IMiS®/View Manual Version 10.4.2310 
 

2023 ©  MARGIS, Inc., All rights reserved. 94 
 

 

7.6 Moving pages 

You can arrange the pages within a document in a random order. Select the page(s) you wish 

to move and drag & drop them to the desired location. In order to do so, the document has to 

be in edit mode. 

While moving the document pages, the mouse cursor on the page changes to . 

 

The following dialog box appears: 
 

 

Image 76:  Moving page(s) notification 
 

By clicking on the "Yes" button, the selected page(s) will be moved to the newly selected 

location. 

If the page cannot be moved, the mouse cursor on the page changes to  when trying to 

move it. 

When moving pages, pay attention to the cursor position on the page. If the cursor 

flickers before a page when dropping a page, this means that you will insert the page before 

this one; if not, the page will be inserted after it. 
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7.7 Opening a document 

The IMiS®/Scan application can be used for viewing all of the most commonly used image file 

formats such as TIFF, PDF, BMP, JPEG, GIF etc. 

For more information see chapter Recording of scanned documents. 

 

By right-clicking on the IMiS® icon  in the taskbar, you can open an existing document. 

The "Tools" menu appears, from which you select "Open document" 
 

 

Image 77:  Opening a document from the “Tools” menu 
 

Double-click on the IMiS icon . 

 

In an open IMiS®/Scan user window you can open a document in the "File" menu by clicking on 

the "Open" option.  

 
Image 78:  Selecting "Open" command from the "File" menu 
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A dialog box appears, showing all the image files located in the currently selected folder. 

Find and select the desired file and confirm the selection by clicking on the "Open" button. 

 

In the toolbar click on the "Open existing document" icon . 

In Windows Explorer double-click on the desired file. If a file extension is associated with 

the IMiS®/Scan application, the file will automatically open in the IMiS®/Scan application. 

Drag the desired file from Windows Explorer to the open IMiS®/Scan user window.  

The file opens in a newly opened IMiS®/Scan window. 

 

A document can also be opened via an application programming interface from third-party 

applications; in this case the documents are saved on IMiS®/ARChive Server. 

 

7.7.1 Procedure of opening an existing document 

The procedure is started by opening a new user window in which the selected document 

appears. While opening the document, the user window displays a notification window stating 

that the document is being prepared for reading. 

 

While this notification is being displayed, the following procedures are executed: 

• The original document is copied to a temporary file. 

• If the document contains an digital signature, its validity is verified. 

• If the document contains redactions and the user does not have editing rights for the 

document, all of the redactions are merged with the document. 

• Based on the user rights for this document, certain commands, and actions in 

IMiS®/Scan are disabled. 

 

The scanned document is shown in reading mode and cannot be changed nor pages added.  

The title bar of the user window and the "Tools" menu show the name of the document. 
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  In the event that the document cannot be found on IMiS®/ARChive Server, 

the following notification appears: "Error <DOCIO_FILENOTFOUND> when opening document.". 

 

If the document is not located in the file system, the following notification appears:  

"Error <DOCIO_INVALIDPARAM>when opening document.". 

 

7.8 Description of the user window of an existing document 

The user window of an open document enables only those actions and commands that do not 

modify the document contents. You can switch to edit mode by clicking on the "Enable mode" 

option in the "Edit" menu. By doing so, you can add new pages, remove existing pages, change 

the page order or add annotations to documents. 
 

The edit mode can also be accessed by clicking on the "Enable edit mode" icon  in the 

toolbar. 

 

7.8.1 Status bar 

The status bar of a user window contains information about the current page, page insertion 

method, scale, rotation, flip, page size in pixels, color depth and file format of a new or open 

document. For more information see chapter Document details. 
 

 

Image 79:  Viewing status bar 
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7.8.2 Document details 

In addition to an image of the page, each page in a document also contains metadata about the 

scanned document. 

In order to display this data, click on the "Document information" category in the right pane.  

It can also be displayed by clicking on the "Information" option in the "Page" menu. 
 

 

Image 80:  Selecting "Information” command from the "Page" menu 
 

By clicking on the "Show page Information" icon  or the "Alt+Enter" key combination, 

document details are displayed. 

 
Image 81:  Selecting the right pane "Document information" 
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The following page details are displayed: 

• Page name. 

• Page width and length in pixels. 

• Horizontal and vertical resolution in dots per inch (dpi). 

• Number of patterns per pixel and number of bits per pattern, which determine the image 

color depth. 

• Image orientation:  portrait, landscape, rotate or flip. 

• The compression mode shows the name of the used compression mode. 

For more information see chapter Scanning resolution and quality. 

• Compressed image size when using the previous compression method. 

• Software:  name of the application which created the page or document. 

• Date created:  date and hour when the page or document was created. 

• Author of the page or document. 

• The name of the computer on which the page or document was created.  

This detail is available only for TIFF file formats. 

• Date modified:  shows the date and hour of the last modification to the document. 

• The attributes which do not exist are labeled "Not available". 

• “Signed”:  shows whether the document has been signed or not. 

For more information see chapter Digital signing of a document. 

 

In the case of the PDF file format these details refer to the entire document, since the PDF 

format does not enable the saving of metadata for individual pages. 

 

7.8.3 Toolbar 

Commands are executed in IMiS®/Scan via the menu, the toolbar, "Tools" menu, right pane or 

keyboard. The toolbar is intended for the use of the most frequently used commands of the 

IMiS®/Scan application. 

 

The commands are combined into five toolbar groups: standard, scan, tools, page, view. 
 

 

Image 82:  The toolbar 
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Each group can be moved or hidden randomly. It can be moved by dragging its handle  to the 

desired location. By right-clicking above the toolbar or menu, the "Tools" menu appears, 

in which you select the bar you wish to hide or show. 
 

 
Image 83:  Selecting the bar to hide or show 

 

By clicking on the "Default" option, all the bars are shown and placed in the default location. 

 

7.9 Sending a document by email 

A currently open document is sent by email by clicking on the "Send" option in the "File" menu. 
 

 
Image 84:  Selecting "Send" command from the "File" menu 

 

The sending action can also be executed by clicking on the "Send active document by 

mail" icon  or by using the "Ctrl+M" key combination. 
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By clicking on the "Send" option, a dialog box appears, in which you can set the options before 

exporting the document. 
 

 

Image 85:  Setting parameters in the "Export options" dialog box 
 

If you have selected "Hide export options dialog" in the “Export” category, this dialog box will 

not appear. The default export settings will apply. For more information see chapter Setting 

options – Export. 

 

The options shown in the dialog box depend on the document contents. If the document does 

not contain a digital signature, the "Options" group is not available. 

 

The document can be sent by email in another image format. You can choose between the 

Multiple TIFF and Adobe PDF file formats. The same goes for the "Merge settings" group, which 

does not appear if the document does not contain annotations. 

 

When selecting the sending of a document copy, you can select which types of annotations will 

be merged with the document. The unselected annotation types will not be transferred to the 

copy. 

 

The "Settings" group appears only if one of the pages has been rotated/ mirrored. 
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After confirming the settings, the default email client creates a new email to which this 

document is attached. The email must be completed by adding the email address of the 

recipient. 

 

Warning:  Color annotations on a black-and-white page, which are set to be "merged" when sent, are 

changed to a shade of gray. 

 

7.10 Exporting a document to a file system 

A currently open document can be sent by email by clicking on the "Export as" option in the 

"File" menu. 
 

 

Image 86:  Selecting "Export as" command from the "File" menu 
 

By using the "Ctrl+E" key combination. 

 

By clicking on the "Export as" option, a dialog box for saving files appears. Enter the name of the 

new document and select the file format. You can choose between the Multiple TIFF and Adobe 

PDF file format. For more information see chapter File compression and size. 
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By clicking on the "Save" button, a dialog box appears with the option of selecting additional 

export settings. For more information see chapter Sending a document by email. 
 

 
Image 87:  Setting parameters in the "Export options" dialog box 

 

After confirming the settings, a new file with the previously entered name is created in the 

selected file location. 

 

Warning:  Color annotations on a black-and-white page, which are set to be "merged" when saved, are 

changed to a shade of gray. 

 

7.11 Printing a document 

A document is printed by clicking on the "Print" option in the "File" menu. 
 

 

Image 88:  Selecting "Print” command from the "File" menu 
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A dialog box for printing appears, in which you select the printer and the pages to be printed. 
 

 
Image 89:  Setting parameters in the "Print" dialog box 

 

In the box, set the parameters of the currently selected printer. By clicking on the "Print" 

button, you send the document or selected pages to print. 

By clicking on the "Print" icon  in the toolbar, the default printer starts the printing 

procedure, without showing the dialog box for printing. 

 

7.12 Inverting colors 

This functionality enables changing the document image into a negative. In the case of scanned 

documents with poorer quality this can improve the readability of the contents. The inverting 

of colors is turned on with the "Invert" command in the "View" menu. 
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Image 90:  Selecting "Print” command from the "View" menu 
 

7.13 Rotating and mirroring pages 

Every page in the document can be rotated to the left or right by 90o. You can also select the 

rotation of a document by 90 o, 180 o or 270 o to the right. Rotating to the left or right is 

performed by clicking on the "Rotate left" or "Rotate right" options in the "Orientation" menu 

and the "View" menu. 

 
Image 91:  Selecting "Orientation” command from the "View" menu 

 

In the toolbar select the "Rotate left"  or "Rotate right"  icon.  

With the "Ctrl + Left arrow key" or "Ctrl + Right arrow key" key combination. 
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An image is mirrored by clicking on the "Mirror" option in the "View" menu. 
 

 
Image 92:  Selecting "Mirror” command from the "View" menu 

 

If you wish to permanently save this new page orientation, save the document, which must be 

in edit mode.  

 

Note:  Saving a document with changed page orientation means that the contents of the scanned 

document are modified and therefore the document no longer matches the original one. 

 

7.14 Page zooming 

Pages which are too big or too small can be zoomed in/zoomed out to the desired zoom level. 

Pages are zoomed by zoom percentages or in accordance with the size of the user window. 

The zoom percentage is changed by clicking on the "Zoom Out" or "Zoom In" option in the 

"View" menu. 

 
Image 93:  Selecting "Zoom Out/In” command from the "View" menu 
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In the toolbar select the "Zoom Out"  or "Zoom In" icon . 

With the "+" or "-" keys on the numeric keypad. 

With the "Ctrl key and by simultaneously moving the scroll wheel". 

 

Zoom selection is performed in accordance with the size of the user window by clicking on the 

"Zoom" option in the "View" menu. For more information see chapter Setting options – View. 

By clicking on the toolbar icons: "Actual size" , "Show whole page" , "Page width" 

 or "Page height" . 

 

The zooming of a specific area of the image is achieved by clicking on the "Zoom" option in the 

"Mouse mode" submenu in the "Tools" menu. 
 

 
Image 94:  Selecting "Zoom” command from the "Tools" menu 

 

The mouse cursor changes to a magnifying glass  and you mark the area you wish to zoom 

by dragging it. The zoomed area can be changed back with the above-mentioned options, e.g. 

the "+" or"-" keys. 
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7.15 Viewing a page 

More detailed viewing of the contents of a scanned document is easier if the page view has 

been enlarged; the arrow keys are used for scrolling through the page. You can also change the 

operation mode to "View", which changes the mouse cursor to a hand . By holding the left 

mouse button and moving the mouse, you scroll through the page. You can find the "View" 

operation mode by clicking on the "Pan" option in the "Mouse mode" submenu in the "Tools" 

menu. 

 
Image 95:  Selecting "Pan” command from the "Tools" menu 

The "Pan option can also be activated from the toolbar by selecting the "Pan mouse 

mode" icon.  

 

7.16 Region selection 

Region selection is used when you wish to mark a section of a page or contents in a document.  

In the "Tools" menu, select the "Mouse mode" submenu and the "Region" option within it. 

Then place the cursor on the section of the document you wish to mark. Mark the desired 

region by left-clicking and dragging. 

 

 
Image 96:  Selecting "Region” command from the "Tools" menu 
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In the toolbar select the "Region mouse mode" icon.  
 

 

Image 97:  Selecting the region in the document 
 

By clicking and holding the left mouse button in the selected region, you can move this region 

across the page. 

After the region has been placed in the desired location, you can use the "Copy" or "Paste" 

function.  

 

Copy selection to clipboard 

You copy a part of an image by clicking on the "Copy selection to clipboard" icon . 

 
Insert clipboard contents 

The contents in the clipboard can be inserted into the currently open document or into a new 

document as a new page. They are inserted by clicking on the "Insert clipboard contents" icon 

 in the toolbar. 

 

Cropping a part of an image 

Use the cropping of a part of an image when you wish to keep only the contents marked with 

this region and not the entire page. By right-clicking on the selected region, the "Tools" menu 

appears. Cropping is performed by right clicking on the "Crop" option. 
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By doing so, the current page is deleted and replaced with the contents of the selected area. 
 

 
Image 98:  Selecting "Crop” command from the "Tools" menu 

 

7.17 Saving and closing a document 

After finishing the scan or modification of an existing document, this document can be saved by 

clicking on the "Save and Close" option in the "File" menu. 
 

 
Image 99:  Selecting "Save and close” command from the "File" menu 
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By clicking on the "Save and Close" icon  in the toolbar or with the "Ctrl+Q" key 

combination. After saving is complete, the IMiS®/Scan user window closes. 

 

If you wish to save a document without closing it, select "Save". 

 

By clicking on the arrow by "Save and Close" icon  in the toolbar, the "Save" icon 

appears. Click on it. 

With the "Ctrl+S" key combination. 
 

 
Image 100:  Selecting "Save and Close” icon in the toolbar 

 

If the document has not yet been named, a window for saving files opens, in which you specify 

the name of the document and the folder to which it will be saved. After clicking on the "Save" 

button, the document is saved. 
 

Note:  During the saving stage, the contents of an digitally signed document are digitally signed with a 

previously selected digital certificate. Subsequent modifications invalidate the digital signature. 

 

If you modify or add annotations to an existing document, the following dialog box appears 

when saving it: 

 

Image 101:  Saving document with annotations notification 
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By clicking on the "Yes" button, all of the modified annotations are saved in the document.  

By clicking on the "No" button, all modifications to the annotations are discarded.  

By clicking on the "Cancel" button, you abort saving and return to the IMiS®/Scan user window. 

 

7.17.1 Closing a document 

The IMiS®/Scan user window can be closed by clicking on the cross  in the window's title 

bar or with the "Esc" key. Closing with the "Esc" key must be turned on in the application 

settings. For more information see chapter Setting options – General. 

 

If the document has been modified and not yet saved prior to closing, the following dialog box 

appears: 

 
Image 102:  Saving document with changes notification 

 

By clicking on the "Yes" button, the document is saved and the user window closes. 

By clicking on the "No" button, all changes to the document are discarded and the user window 

closes. 

By clicking on the "Cancel" button, you return to the user window without saving the changes. 

 

7.18 Annotations 

IMiS®/Scan offers various types of annotations for highlighting or hiding important parts of the 

content of scanned documents. Annotations can be added, modified or deleted, for which you 

must have the appropriate rights. For more information see chapter Setting Annotation 

Rights. 
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The document must be in edit mode. Changes to annotations are preserved only by saving the 

document. 
 

Warning:  Saving annotations is possible only for the TIFF format. If the user adds an annotation to the 

document in the PDF/A format, when saving the document, the user will be shown the notification that 

the annotation will not be saved to this document. 

 

7.18.1 Annotation tools 

Annotations are edited via the "Annotations" category in the right pane. By clicking on an 

individual annotation icon, the settings for the selected annotation appear in the bottom part of 

the "Annotations" category. The last selected annotation tool is saved as default when closing 

the user window and is hence automatically selected when you wish to add an annotation to 

another document. The document has to be in edit mode.  

The value of the last selected annotation tool is saved in the Windows registry in the 

LastAnnotationSelected field in the HKEY_CURRENT_USER\Software\IS\IMiS\IMiSScan subkey. 

 

The table describes all of the available annotation tools. 
 

 Tool preservation mode. Every time you use an annotation tool it becomes the default 

active selection tool. By selecting this icon, you enable the annotation tool preservation 

mode, which means that after you select an annotation tool that tool remains active for 

reuse, namely until you select another tool. In the "Annotations" category in the 

"Preferences" submenu in the "Tools" menu, set the default status of the tool 

preservation mode. For more information see chapter Setting options. 

 

 

 

Selection tool. An individual annotation is selected by left-clicking. If you wish to 

simultaneously select several annotations in a document, left-click and drag to mark the 

area in which the desired annotations are located.  

 
Text annotation. Place a text annotation in a scanned document. A flickering mouse 

cursor appears in a box into which you write a random text. After entering the text, click 

outside of the annotation text box. The text and text format can be edited by changing 

the properties in the right pane. 
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 Highlighting tool. This annotation is used for highlighting contents in the scanned 

document. Drag a rectangle across the area you wish to highlight. The highlight color is 

set in the right pane. 

 Redaction tool. It is used to hide specific parts of a document. The redaction is dragged 

across the region you wish to hide and its color is changed if need be (in properties). 

The redacted contents are visible only to users with the right to see through the 

redaction. For more information see chapter Setting annotation rights. 

 Comments. Click on the location in which you wish to add a comment. Write the 

comment and specify the caption which will be shown beneath the comment icon. By 

double-clicking on the comment icon, you open and edit the comment. In the right pane 

you can edit additional settings, such as: text, icon image, comment colors etc. 

 Arrow tool. Select this tool when you wish to draw arrows in the image. Define the 

properties for the head and tail of the arrow, an additional caption etc. 

 Line. This annotation is used for drawing lines freehand. In the right pane set the line 

thickness and color. 

 Annotation in the shape of an ellipse. It is used for drawing ellipses. In the right pane 

you can set the background color of the ellipse. 

 Rectangular annotation. Draw a rectangle in the image. As with the ellipse, fill the 

rectangle with the desired background color. 

 Line breaking tool. This annotation is used for drawing broken lines. Drawing is 

concluded by double-clicking on the left mouse button in the desired location. In the right 

pane set the color and/or thickness of the line and/or background. 

 Image annotation. This annotation is used when wishing to insert an image annotation 

into a document. If the file path to the image is not specified in the right pane, a dialog box 

for opening files appears, in which you select the path to the image file. IMiS®/Scan 

enables only the insertion of the BMP file format. 

 Stamp annotation. This annotation is used for preselected images, which are specified 

in the "Annotations" category in the "Options" menu in the "Tools" menu. 

For more information see chapter Setting options – Annotations. 
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User annotations. Annotations appear which the user has previously saved and which 

can be selected for reuse. 

 

7.18.2 Editing annotations 

In order to edit the annotation settings, the document must be in edit mode and the 

"Annotations" category must be opened in the right pane. When using IMiS®/Scan through 

another application, you need appropriate rights for editing annotations. 

For more information see chapter Setting annotation rights. 

 

Select an existing annotation in the document or an icon in the annotations bar. 

The settings for this annotation appear in the right pane. 
 

    
Image 103:  Annotation settings in the right pane "Annotations" 
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7.18.3 Copying and merging annotations 

In IMiS®/Scan annotations can be copied, cut or inserted to other pages of the document or 

into other documents. Select an annotation by right-clicking. 
 

 
Image 104:  Selecting "Copy” command from the “Tools” menu 

 

Select the desired action from the "Tools" menu. 

You can merge an individual annotation in the document with the document. By doing so,  

the annotation becomes a part of the scanned document. 
 

Note:  By merging annotations, you modify the document contents. 

 

7.18.4 Setting annotation rights 

  You can set the rights of a user for each type of annotation.  

The rights can be set only through another application. When invoking the window for setting 

rights in another application, the following options appear: 
 

 
Image 105:  Setting annotation rights in another application 
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You can specify for each type of annotation whether a user has the right to see it in a 

document and whether the user has the right to add new annotations to a document. 

 

Warning: During redaction you set the rights of a user for viewing the redacted contents.  

If the user does not have that right, the redaction stays in the document and the user cannot remove it. 

 

7.18.5 User annotations 

All annotations in a document can be saved for reuse. They are available to the person who 

saved the annotation. By right-clicking on the desired annotation, the "Tools" menu appears. 
 

 

Image 106:  Selecting "Save Annotation As” command from the “Tools” menu 
 

Select "Save annotation as" from the menu and then select "New annotation". A dialog box 

appears in which you enter the user annotation name. 
 

 
Image 107:  Saving custom annotation 

 

Confirm the entry by clicking on the "OK" button.  

 

The annotation can be invoked to the document by selecting the annotation name. User 

annotations are selected by clicking on the "User annotations" icon  in the annotations bar.  

A list of saved annotations appears. 
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The selected annotation is placed in the document in the same location as it was inserted when 

being saved. It can be manually dragged to another location in the document with the mouse. 

 

If you have selected the default option "Enable custom annotation mouse move" in the settings, 

the user annotation is not immediately placed in the document. The location of the annotation 

is selected by moving the mouse and clicking on the selected location in the document. 

 

A user annotation can be selected from the drop-down menu in the "Custom" tab under the 

"Annotations" category. 

 

Image 108:  Selecting the custom annotation 
 

To delete a saved user annotation, select the annotation and click on the "Delete" button.  

The user annotation is removed from the list. 

User annotations are saved in the Windows registry in the 

HKEY_CURRENT_USER\Software\IS\UserAnnot subkey. The value of each user annotation is 

recorded in the field containing the name of the user annotation. 
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7.19 Arranging user windows 

The easiest way to arrange several simultaneously open windows is by using the "Window" 

menu. 

 

Image 109:  Arranging user windows from the "Window" menu 
 

Open documents can be arranged in one of the following ways: 

• One after another in a cascade. 

• Distributed horizontally, side-by-side. 

• Distributed vertically, one beneath the other. 

 

7.20 "Help" menu 

By clicking on the "IMiS Homepage" option, the default Internet browser opens the website of 

Imaging Systems Inc. (http://www.imis.eu). 

 

By clicking on the "IMiS Manual" option, the default Internet browser opens the first page of the 

user manual. 

 
Image 110:  Selecting "IMiS Homepage” command from the “Help” menu 

 

By clicking on the "IMiS Tech Support" option, the default email client creates a new message 

for the addressee  support@imis.eu. The message contents contain information about the 

installed version of the IMiS®/Scan application and utility libraries. Attached to the message is 

the operations log for the IMiS®/Scan application in connection with IMiS®/ARChive Server. 
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This information helps technical support eliminate problems. 
 

 
Image 111:  IMiS® Technical support request 

 

By clicking on the "About" option, the splash screen of the IMiS®/Scan application appears, 

which contains details about the application version. 
 

 

Image 112:  The information about the product version 
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7.21 Digital signing of a document 

7.21.1 Setting and adding a signature 

Documents scanned with the IMiS®/Scan application can be digitally signed. 

A digital signature can be a mere electronic record in the document, which is not visible to the 

user, or can be graphically depicted and visible to the user when viewing the document in a 

viewer. Signature settings are edited in the "Signature" category in the right pane of the user 

window. 

 
Image 113:  Digital signature settings in the right pane "Signature" 

 

Settings for digital signing are possible only if: 

• the document is in edit mode; 

• a certificate is installed on the computer; 

• the document you wish to sign is not empty. 

 

Before signing it digitally, select a digital certificate. The default digital certificate setting is 

selected in the "Signature" category in the "Preferences" submenu in the "Tools" menu. 

 

Detailed information about the currently selected digital certificate can be viewed by clicking on 

the "Certificate information" button  in the "Select certificate" group. 

A window opens containing a notification and digital certificate details. 
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In the "Components" group, select which information about the digital signature will be shown 

in the scanned document. The options are as follows: 

• Text description of the digital certificate. 

• Image of a handwritten signature or any other visual mark. 

• Signature reason, which can be saved to be reused in the next signing session. 

• Visible comments to the document. 

 

A document can also be digitally signed without any visible marks on the document. 
 

By clicking on the "Save" button, all the digital signature settings are saved for later, faster use. 

Likewise preserved are the size and current position of the visible part of the signature. 
 

By clicking on the "Reset" button, the changed settings are set to their previous values. 

Digital signing is performed by clicking on the "Add signature on document" icon . 

Place the selected components of the visible signature to the desired location in the document 

using the mouse. 

By doing so, the document is not yet digitally signed. The document is signed when it is saved, 

because then the entire contents of the document are uniformly coded, together with the 

digital certificate, and recorded into the document.  

This procedure is also temporarily executed when printing or sending by email. 
 

 
Image 114:  Adding digital signature to the document 

 

You can add digital signatures of other users to a document which has already been signed by 

a user. A document can be signed by several users in a row or in parallel. 
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7.21.2 Showing of digitally signed documents 

Before showing a digitally signed document in the user interface, the validity of the signatures 

is verified. The verification result is shown visually in the user window, next to each signature in 

the document. 
 

Visual Mark Description of the Mark's Meaning 

 

The document contents have not been modified after being signed and the 

signer's digital certificate is valid. 

 

The document contents have not been modified after being signed, however, 

the signer's digital certificate has expired. 

 

The document contents have been modified after being signed or the signer's 

digital certificate is invalid.  

 

For more detailed information about the digital signature click on the "Details” tab in the right 

pane in the "Signature" category. Signatures which are not visually presented in the document 

are also listed here. 

 

Image 115:  Digital signature details in the right pane "Signature" 
 

By clicking on the "Deep verification" button, you activate the procedure of the detailed 

verification of the validity of the signer's digital certificate. 
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The "Signer(s)" group contains a tree view of all the metadata for an individual digital signature, 

where is shown the: 

• validity of the signature; 

• date the signature was created; 

• reason for the signature; 

• signature comment; 

• validity of the signer's certificate; 

• presence of a timestamp; 

• expiration date of the certificate; 

• signature version; 

• application with which it was created. 

 

By clicking on the "Locate signature" parameter in the tree view, a page appears in the central 

part of the user window, which contains the signature. 
 

By double-clicking on the certificate image  or by clicking on the "Display certificate..." 

parameter in the tree view, a dialog box appears, containing all the details of the signer's 

certificate. 

 
Image 116:  Displaying signer(s) certificate(s) 
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7.21.3 Editing a digitally signed document 

In the IMiS®/Scan application you can edit or digitally sign a document with your own signature. 

In both cases the document must be set to edit mode. 

This is performed by clicking on the "Enable edit mode" icon  in the toolbar. 

The following dialog box appears: 
 

 

Image 117:  Document modification notification 
 

Confirm the selection by clicking on the "Yes" button. 

 

By modifying the contents of an already signed document, you invalidate all existing digital 

signatures in the document. 
 

 
Image 118:  Modifying the contents of signed document 

 

A document modified this way can be signed again with your own certificate, removing all of the 

visible parts of the invalid signatures in the document from the document.  
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Their presence in the document is visible only in the "Signatures" category in the "Details" tab 

in the "Signer(s)" list. 
 

 

Image 119:  Validity of the digital signatures in the document 
 

It may occur that while you are viewing a document in reading mode another user modifies the 

document and, consequently, the validity of the signatures. If the document contents have been 

modified while you were viewing the document, it is reread from the file system. The validity of 

digital signatures is likewise verified anew. 

 

7.21.4 Digital signing of a document through another application 

If IMiS®/Scan is integrated in a different application, it is possible to perform an digital signing 

of a document without using the user interface. TIFF and PDF/A documents can be signed.  

For more information see chapter Integration of IMiS®/Scan into another application. 
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IMiS®/Scan supports two solutions for signing documents in such a way: 
 

• integration via a C-API solution, which is executed by invoking the imisapi function 

ImiSSignObject 

 

Example of a code in a HCL Notes script: 

C-API 

… 

Declare Function IMiSSignObject Lib "IMiSapi.dll" (Byval StoreType As Long, Byval StoreInfo As String, ObjId 

As String, CertificateIdType As Long, CertificateId As String, SignInfo As SignInfoStruc)  As Long 

… 

'signing a document, with no certificate or a visual stamp given 

rezultat& = IMiSSignObject (Clng(IMiSObjectSty&),StoreInfo,IMiSObjectID$, 0, nil, nil) 

If rezultat& = 20 Then  

  'signing failed 

  … 

 

• integration via a COM interface, which is executed by invoking the Sign method on the 

ImiSDocument object 
 

Example of a code in a HCL Notes script: 

COM 

… 

Set IMiSApp = CreateObject("IMiSClient.Application") 

 

'Connect with IMiS/ARChive Server 

Set IMiSStorage = IMiSApp.OpenIMiSArcStorage("dev-iarc.imis.si", 16810, "Documents") 

 

'Open IMiS document 

Set IMiSObj = IMiSStorage.OpenDocument(documentID) 

  

''signing a document, with no certificate or a visual stamp given 

Rez = IMiSObj.Sign(0, null, null) 

… 
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It is possible to provide a preselected certificate and a visual representation of the signature  

(a BMP file) for both solutions. If the certificate is not specified or doesn’t exist on the 

computer, a certificate selection window will appear during the signing process.  

 

Once you select the certificate, the signing process will begin. The optionally specified visual 

representation of the signature will be added to the document. If the signing fails, both 

solutions will return an error SIGNERROR (20). 

 

The file that we are signing remains unchanged. 

For a more detailed description and use of other parameters contact support@imis.eu. 
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8 TROUBLESHOOTING 

8.1 Launch problems 

8.1.1 Missing libraries 
 

 
Image 120:  Module not properly registered notification example 

 

Cause:  The IMiS®/Scan application has failed to load all libraries to ensure proper operation.  

Most likely, one of them was installed incorrectly or the module versions are incompatible. 
 

Eliminating the error:  Remove the installed IMiS®/Scan product. Reinstall the IMiS®/Scan 

product. In the case that the error reappears, turn to technical support via email: 

support@imis.eu. 

 
8.1.2 Error initializing common tables 
 

 
Image 121:  “Initialization failed” notification 

 

Cause:  The English text in the error description may differ and depends on the cause of the 

error. The most likely cause of the error is insufficient user rights for invoking the Windows 

CreateFileMapping function or incorrect product installation. 
 

Eliminating the error:  Turn to technical support via email: support@imis.eu.  

Based on the English description of the error, technical support will send a suggestion for 

eliminating this error. 
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8.2 Scanning problems 

8.2.1 Cannot communicate with scanner 

Communication with the scanner is not possible or the scanner driver has not been installed. 
 

 
Image 122:  “The scanner is not responding” notification 

 

Cause:  The scanner driver has not been installed in the IMiS®/Scan application or cannot 

establish initial communication with the scanner. 
 

Eliminating the error:  Check the power and data cable from the scanner to the computer. 

Turn the scanner off and then back on. Shutdown and restart the IMiS®/Scan application.  

Check the scanner settings to see if the correct driver for the connected scanner is installed. 

 

8.2.2 Paper jammed in scanner 
 

 

Image 123:  "Paper jammed in scanner" notification 
 

Cause:  The feeder in the scanner has pulled the paper in incorrectly. 
 

Eliminating the error:  Turn the scanner off, physically remove the paper from the mechanism, 

and turn the scanner on. Restart the scan. For some scanner types the IMiS®/Scan application 

must be restarted. 
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8.3 Problems opening documents 

8.3.1 Incorrect document format 
 

 
Image 124:  Unsupported file format notification example 

 

Cause: The document is not written in a file format recognized by the IMiS®/Scan application. 
 

Eliminating the problem: 

• Do not open files with the IMiS®/Scan application in a format which the IMiS®/Scan 

application is not familiar with. 

• If a file has a TIF or PDF extension, but has not been written in the TIFF or PDF/A file 

format, you must assign the proper extension to the file and open it in a viewer which 

supports that format. 

 
 
Cause: The document's file record is incorrect or damaged. 
 

Eliminating the problem: 

• Request an undamaged copy of the document from the author of the damaged 

document. 

• Send the damaged document to support@imis.eu, where technical support will try to 

restore the record. 
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8.3.2 Document cannot be opened in another viewer 

A document which has been created with IMiS®/Scan cannot be opened in another viewer. 
 

 
Image 125:  Document cannot be opened in another viewer example 

 

Cause:  When saving the document, a patented compression method was used which is not 
supported by all programs for viewing. 
 

Eliminating the problem:  Open the document in IMiS®/Scan and convert it to a PDF file format.  

Before saving the document in the IMiS®/Scan application, select another compression 

method. For more information see chapter Setting options – Document. 

 
8.3.3 Document cannot be opened in modification mode 
 

 
Image 126:  Document cannot be opened in edit mode notification 

 

Cause:  The document you wish to edit is already open in modification mode. 
 

Eliminating the problem:  If you have already opened the document in modification mode, close 

it; otherwise wait for the other user to finish editing it. 
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8.3.4 Error #2 when opening a document 
 

 

Image 127: “Document open error #-2” notification 
 

Cause:  This error occurs when reading a document due to an incorrectly provided document 

name or path to the document in the file system. 
 

Eliminating the problem: When opening the document, enter the correct name or path to the 

document. 

 
8.3.5 Error #3 when opening a document 
 

 
Image 128:  “Document open error #-3” error notification 

 

Cause:  This error occurs when opening an unsupported document format. 
 

Eliminating the problem:  Before opening the document choose a supported document format 

(TIFF, PDF/A). 

 

8.3.6 Error #11 when opening a document 
 

 
Image 129:  “Document open error #11” error notification 
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Cause:  Invalid document identifier (object ID), saved on the IMiS®/ARChive Server. 
 

Eliminating the problem:  Provide the correct document identifier (object ID). 

 
 
Cause:  The document does not exist on the IMiS®/ARChive Server. 
 

Eliminating the problem:  Check whether the document is indeed saved on the IMiS®/ARChive 

Server. 

 
 
Cause:  The document is open in another application (Word, Excel) and cannot be transferred 

to the IMiS®/ARChive Server. 
 

Eliminating the problem:  Close the document and try to import it again (File import). 

 
 
Cause:  A temporary file cannot be created in the temporary folder. 
 

Eliminating the problem:  Check whether the user has the rights for writing in the temporary 

folder. 

 

8.4 Problems saving documents 

8.4.1 Error #14 when saving a document 
 

 
Image 130:  “Document save error #14” notification 

 

Cause:  Wrong name of the folder in which you wish to save the document. 
 

Eliminating the problem:  Enter the correct folder name in the dialog box for saving files. 
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Cause:  A document saved on the IMiS®/ARChive Server cannot be copied to a temporary file. 
 

Eliminating the problem:  The administrator checks the user rights for the temporary folder in 

which the temporary file is located. 

 
 
Cause:  The document cannot be saved on the IMiS®/ARChive Server. 
 

Eliminating the problem:   Check the operation of the IMiS®/ARChive Server. 

Turn to technical support via email: support@imis.eu. 

 

8.4.2 Error #201 when saving a document 
 

 
Image 131:  “Document save error #-201” notification 

 

Cause:  The provided IMiS®/ARChive Server profile does not exist. 
 

Eliminating the problem:  Check the entered profile name.  

Turn to technical support via email: support@imis.eu. 

 

8.4.3 Cannot save in the PDF file format 
 

 

Image 132:  Cannot save in the PDF file format notification example 
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Cause:  Unexpected error when saving and closing a new document written in the PDF file 

format. 
 

Eliminating the problem:  Shutdown and restart the IMiS®/Scan application. 

Turn to technical support via email: support@imis.eu. 

 

8.4.4 Cannot save in the TIFF file format 
 

 
Image 133:  Cannot save in the TIFF file format notification example 

 

Cause:  Unexpected error when writing the document in the TIFF format. 
 

Eliminating the problem:  Shutdown and restart the IMiS®/Scan application. 

Turn to technical support via email: support@imis.eu. 

 

8.5 Problems sending documents 

8.5.1 Error sending a document by email 
 

 

Image 134:  “Error sending mail” notification 
 

Cause:  The user has not set a default email client in the Windows operating system. 

This error also appears when the email client does not support Microsoft's MAPI interface for 

connecting the email client to other applications. 
 

Eliminating the problem:  Try restarting the IMiS®/Scan application or computer. 

Turn to technical support via email: support@imis.eu. 
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8.5.2 Error creating an export file 
 

  

Image 135:  “Error exporting document to file” notification 
 

Cause:  An export file cannot be created in the desired location. 
 

Eliminating the problem:  Check the existence of the folder or permissions on the folder to 

which you are exporting the document. 

Turn to technical support via email: support@imis.eu. 

 

8.6 Problems printing documents 

8.6.1 Error selecting printer 
 

  

Image 136:  “No printer has been selected” notification 
 

Cause:  No printing drivers are installed in the Windows operating system. 
 

Eliminating the problem:  Install a printer driver in the operating system; it can be a virtual one 

(i.e., not physically connected to the device). 
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